A Simple Math Problem
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 1691 Accepted Submission(s): 494
Problem Description
Given two positive integers a and b,find suitable X and Y to meet the conditions: X+Y=a Least Common Multiple (X, Y) =b
Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.
Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).
Sample Input
6 8 798 10780
Sample Output
No Solution 308 490
Source
Recommend
wange2014
大体题意:
给你a和b,让你求出X和Y,使得X + Y = a lcm(x,y) = b
思路:
看数据范围肯定不能进行暴力枚举了!
令gcd(x,y) = g;
那么
g * k1 = x;
g * k2 = y;
因为g 是最大公约数,那么k1与k2 必互质!
=> g*k1*k2 = b
=> g*k1 + g * k2 = a;
所以k1 * k2 = b / g;
k1 + k2 = a/g;
因为k1与k2 互质!
所以k1 * k2 和 k1 + k2 也一定互质(一个新学的知识点= = )
所以a/g 与b/g也互质!
那么g 就是gcd(a,b);
所以我们得出一个结论: gcd(x,y) == gcd(a,b);;
所以x + y 与 x * y都是已知的了,解一元二次方程即可!
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
ll gcd(ll a,ll b){
return !b ? a : gcd(b, a%b);
}
int main(){
ll a,b;
while (~scanf("%lld %lld",&a, &b)){
int g = gcd(a,b);
ll B = b * g;
ll q = a*a - 4LL * B;
if (q < 0) {
puts("No Solution");
continue;
}
bool ok = 1;
ll tmp = sqrt(q);
if (tmp * tmp != q) ok = 0;
ll a1 = (a + tmp);
ll a2 = (a - tmp);
if (a1 & 1 || a2 & 1) ok = 0;
ll ans1 = min(a1,a2);
ll ans2 = max(a1,a2);
if (ok)printf("%lld %lld\n",ans1/2,ans2/2);
else puts("No Solution");
}
return 0;
}