POJ 2506 Tiling

Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7437 Accepted: 3635

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251


特别注意输入0,输出1!!!!!!!

递推公式不难,Ai=Ai-1+2*Ai-2,很容易就想清楚了



AC代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;

int a[300][3005],b[3005];
int x,y,z;

void work(int c)
{
    int i;
    memset(b,0,sizeof b);
    for(i=0;i<=x;i++)
    {
        b[i]+=(a[c-2][i]*2);
        if(b[i]>10)
        {
            b[i]=b[i]%10;
            x++;
            b[i+1]=1;
        }
    }
    z=x+2;
    for(i=0;i<=z+2;i++)
    {
        a[c][i]+=a[c-1][i]+b[i];
        if(a[c][i]>=10&&i==z+1)
            z++;
        if(a[c][i]>=10)
        {
            a[c][i]=a[c][i]%10;
            a[c][i+1]=1;
        }

    }
    x=y;y=z;
}

int main()
{
    int n;
    int i;
    while(cin>>n)
    {
        if(n==0)
        {cout<<"1"<<endl;continue;}
        int bj=0;
        memset(a,0,sizeof a);
        a[1][0]=1;a[2][0]=3;
        x=0;y=0;
        for(i=3;i<=251;i++)
           work(i);
        for(i=z-1;i>=0;i--)
        {
            if(bj==0&&a[n][i]==0)
            continue;
            if(a[n][i]!=0)
                bj=1;
            cout<<a[n][i];
        }
        cout<<endl;
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值