Tree Summing - UVa 112 简单二叉树(丧病的数据输入)

 Tree Summing 

Background

LISP was one of the earliest high-level programming languages and, with FORTRAN, is one of the oldest languages currently being used. Lists, which are the fundamental data structures in LISP, can easily be adapted to represent other important data structures such as trees.

This problem deals with determining whether binary trees represented as LISP S-expressions possess a certain property.

The Problem

Given a binary tree of integers, you are to write a program that determines whether there exists a root-to-leaf path whose nodes sum to a specified integer. For example, in the tree shown below there are exactly four root-to-leaf paths. The sums of the paths are 27, 22, 26, and 18.

picture25

Binary trees are represented in the input file as LISP S-expressions having the following form.

 
empty tree 		 ::= 		 ()

tree ::= empty tree tex2html_wrap_inline118 (integer tree tree)

The tree diagrammed above is represented by the expression (5 (4 (11 (7 () ()) (2 () ()) ) ()) (8 (13 () ()) (4 () (1 () ()) ) ) )

Note that with this formulation all leaves of a tree are of the form (integer () () )

Since an empty tree has no root-to-leaf paths, any query as to whether a path exists whose sum is a specified integer in an empty tree must be answered negatively.

The Input

The input consists of a sequence of test cases in the form of integer/tree pairs. Each test case consists of an integer followed by one or more spaces followed by a binary tree formatted as an S-expression as described above. All binary tree S-expressions will be valid, but expressions may be spread over several lines and may contain spaces. There will be one or more test cases in an input file, and input is terminated by end-of-file.

The Output

There should be one line of output for each test case (integer/tree pair) in the input file. For each pairI,T (I represents the integer, T represents the tree) the output is the string yes if there is a root-to-leaf path in T whose sum is I and no if there is no path in T whose sum is I.

Sample Input

22 (5(4(11(7()())(2()()))()) (8(13()())(4()(1()()))))
20 (5(4(11(7()())(2()()))()) (8(13()())(4()(1()()))))
10 (3 
     (2 (4 () () )
        (8 () () ) )
     (1 (6 () () )
        (4 () () ) ) )
5 ()

Sample Output

yes
no
yes
no

题意:给你一个数,问你这个数中从最上方的节点到某个末端节点的和能不能出现等于这个数的情况。树的表示方式为5(……)(……)里面可能套树,末端节点为5()();   

这道题如果要用比较短的代码的,需要用到cin.peek()和cin.ignore();  这两个每次都是操作一个字符,cin.peek()可以预读这个字符,然后判断你的操作,操作完后用cin.ignore(),再判断下个字符。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int sum;
bool flag;
void space()
{ while(cin.peek()==' ' || cin.peek()=='\n') //忽略所有的空格和回车
   cin.ignore();
}
bool solve(int ret)  //ret为到当前节点累计的和
{ space();
  cin.ignore();   //忽略(
  space();
  if(cin.peek()==')')  //如果碰到)就说明一个到头了
  { cin.ignore();
   if(ret==sum)
     return true;
   else
     return false;
  }
  int m,sign=1;  //sign判断负数
  if(cin.peek()=='-')
  { sign=-1;
    cin.ignore();
  }
  space();
  cin>>m;
  bool left=solve(ret+m*sign);
  bool right=solve(ret+m*sign);
  if(left&&right)  //之所以是&&是因为末端的一个数后面肯定是()(),已试过||会WA,因为会有()(……)的情况
   flag=true;
  space();  //最后的)
  cin.ignore();
  return false;
}
int main()
{ while(~scanf("%d",&sum))
  { flag=false;
    solve(0);
    if(flag)
     printf("yes\n");
    else
     printf("no\n");
  }
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值