Balanced Number - HDU 3709 数位dp

Balanced Number

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2236    Accepted Submission(s): 995


Problem Description
A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job
to calculate the number of balanced numbers in a given range [x, y].
 

Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18).
 

Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
 

Sample Input
  
  
2 0 9 7604 24324
 

Sample Output
  
  
10 897
 

题意:平衡数的定义为可以找到其中一个数字为支点,两侧的数字乘以到支点的距离的和相同。

思路:数位dp,具体实现看代码吧。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
ll dp[20][20][2010];
int num[20];
//pos为当前到处理的位置,o为支点位置,l为当前已知的力矩,f为是否限制大小
ll dfs(int pos,int o,int l,int f)
{ if(pos<o && l==0)
   return 1;
  if(pos<=0 || l<0)
   return 0;
  int m,i,j,k,ret;
  ll ans=0;
  if(f==1)
   m=num[pos];
  else
   m=9;
  if(f==0 && dp[pos][o][l]!=-1)
   ans=dp[pos][o][l];
  else
  for(i=0;i<=m;i++)
  { ret=l+(pos-o)*i;
    if(f==1 && i==num[pos])
     k=1;
    else
     k=0;
    ans+=dfs(pos-1,o,ret,k);
  }
  if(f==0)
   dp[pos][o][l]=ans;
  return ans;
}
ll solve(ll n)
{ if(n<0)
   return 0;
  ll ret=n,ans=0;
  int i,j,k,len=0;
  while(ret)
  { num[++len]=ret%10;
    ret/=10;
  }
  for(i=1;i<=len;i++)
   ans+=dfs(len,i,0,1);
  return ans-len+1;//除去全为0的情况
}
int main()
{ int t,i,j,k;
  ll l,r;
  memset(dp,-1,sizeof(dp));
  scanf("%d",&t);
  while(t--)
  { scanf("%I64d%I64d",&l,&r);
    printf("%I64d\n",solve(r)-solve(l-1));
  }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值