Carmichael Numbers - UVa 10006 素数判断

32 篇文章 0 订阅

Carmichael Numbers

An important topic nowadays in computer science is cryptography. Some people even think that cryptography is the only important field in computer science, and that life would not matter at all without cryptography. Alvaro is one of such persons, and is designing a set of cryptographic procedures for cooking paella. Some of the cryptographic algorithms he is implementing make use of big prime numbers. However, checking if a big number is prime is not so easy. An exhaustive approach can require the division of the number by all the prime numbers smaller or equal than its square root. For big numbers, the amount of time and storage needed for such operations would certainly ruin the paella.

However, some probabilistic tests exist that offer high confidence at low cost. One of them is the Fermat test.

Let a be a random number between 2 and n - 1 (being n the number whose primality we are testing). Then, n is probably prime if the following equation holds: 

\begin{displaymath}a^n \bmod n = a\end{displaymath}

If a number passes the Fermat test several times then it is prime with a high probability.

Unfortunately, there are bad news. Some numbers that are not prime still pass the Fermat test with every number smaller than themselves. These numbers are called Carmichael numbers.

In this problem you are asked to write a program to test if a given number is a Carmichael number. Hopefully, the teams that fulfill the task will one day be able to taste a delicious portion of encrypted paella. As a side note, we need to mention that, according to Alvaro, the main advantage of encrypted paella over conventional paella is that nobody but you knows what you are eating.

Input 

The input will consist of a series of lines, each containing a small positive number  n  (  2 <  n  < 65000). A number  n  = 0 will mark the end of the input, and must not be processed.

Output 

For each number in the input, you have to print if it is a Carmichael number or not, as shown in the sample output.

Sample Input 

1729
17
561
1109
431
0

Sample Output 

The number 1729 is a Carmichael number.
17 is normal.
The number 561 is a Carmichael number.
1109 is normal.
431 is normal.

题意:题目提供一种筛选素数的方法,对于一个数n,如果许多2<=a<n,使得a ^n%n==a,则n有很大可能是素数。然而有些数不是素数,但是对于所有的a都满足这一点,这样的数成为Carmichael number,求给定的数是不是Carmichael number。

思路:先速筛发求素数,然后对于非素数的需要对于a利用快速幂验证。

注:最后这样的数只用15个,分别为561,1105,1729,2465,2821,6601,8911,10585,15841,29341,41041,46657,

52633,62745,63973。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
int vis[65010];
void init()
{
    int i,j,k;
    for(i=2;i<=300;i++)
       if(vis[i]==0)
         for(j=i*2;j<=65000;j+=i)
         {
             vis[j]=1;
         }
}
bool check(ll a,ll n)
{
    ll k=n,f=1,ret=a;
    while(k)
    {
        if(k&1)
          f=f*ret%n;
        ret=ret*ret%n;
        k/=2;
    }
    if(f==a)
      return true;
    else
      return false;
}
int main()
{
    int n,i,j,k;
    bool flag;
    init();
    while(~scanf("%d",&n) && n>0)
    {
        if(vis[n]==0)
          printf("%d is normal.\n",n);
        else if(vis[n]==2)
          printf("The number %d is a Carmichael number.\n",n);
        else
        {
            flag=true;
            for(i=2;i<n;i++)
               if(!check((ll)i,(ll)n))
               {
                   flag=false;
                   break;
               }
            if(flag)
            {
                vis[n]=2;
                printf("The number %d is a Carmichael number.\n",n);
            }
            else
            {
                vis[n]=0;
                printf("%d is normal.\n",n);
            }
        }
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值