POJ 2182 Lost Cows(牛排序,线段树)

Language:
Lost Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9207 Accepted: 5922

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

Given this data, tell FJ the exact ordering of the cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

Source



给牛排序,n头牛,然后从第二头牛开始给出他在比他序号小这么多牛的地位,最后确定牛的排名


第一次看别人题解惊呆了,f[pos].va--,居然就可以把这个位置腾出来,以后都不会访问,还有一点,从后往前给牛排名


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)
using namespace std;
#define N  8005

struct stud{
int le,ri;
int len;
}f[N*4];

int a[N];
int ans[N];

void build(int pos,int le,int ri)
{
    f[pos].le=le;
    f[pos].ri=ri;
    f[pos].len=ri-le+1;
    if(ri==le)  return ;

    int mid=MID(le,ri);

    build(L(pos),le,mid);
    build(R(pos),mid+1,ri);

}

int query(int pos,int le)
{
   f[pos].len--;

   if(f[pos].le==f[pos].ri)
      return f[pos].le;

   if(f[L(pos)].len>=le)
      return query(L(pos),le);
   return query(R(pos),le-f[L(pos)].len);
}

int main()
{
    int i,j,n;
    while(~scanf("%d",&n))
    {
        build(1,1,n);

        for(i=2;i<=n;i++)
            scanf("%d",&a[i]);

        a[1]=0;

        for(i=n;i>=1;i--)
            ans[i]=query(1,a[i]+1);

        for(i=1;i<=n;i++)
            printf("%d\n",ans[i]);

        return 0;
    }
    return 0;
}









  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值