acm pku 1207 The 3n+1的算法分析与实现

The 3n + 1 problem

Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.
Consider the following algorithm:

        1.              input n
        2.              print n
        3.              if n = 1 then STOP
        4.                             if n is odd then   n <-- 3n+1
        5.                             else   n <-- n/2
        6.              GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1
It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)
Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.
For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0.
You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

Source

Duke Internet Programming Contest 1990,uva 100

 

       分析: 这是一道非常简单的数学模拟题,只需要对算法的过程进行模拟就可以了,但是在编程中,有以下两点需要注意:

l         直接进行搜索比较,时间可能不够(作者并没有试过,但是即使时间足够,直接比较也是比较耗时的),所以可以通过预处理先将1~10000的结果存储下来,以备使用;

l         输入两个数ij时,并不是说先输入的i就一定比j小,所以需要处理:若采用交换ij使得i<=j,则在打印结果时,需要将ij交换回来,切记切记!

 

代码实现:

#include <string.h>

#include "iostream"

using namespace std;

 

int main(void)

{

       long res[10001];

       long i, j, k, n;

       long temp, sum = 0;

       bool changed;

 

       memset(res, 0, sizeof(int)*10001);

       for(i = 1; i < 10001; i++)

       {

              n = i;

              res[i]++ ;

              while(n != 1)

              {

                     if(n%2 == 0) n /= 2;

                     else n = 3*n + 1;

                     res[i]++ ;

              }

       }

 

       while(cin>>i>>j)

       {

              changed = false;

              if(i > j)

              {

                     changed = true;

                     temp = i;

                     i = j;

                     j = temp;

              }

              sum = res[i];

              for(k = i+1; k <= j ; k++)

              {

                     if(sum < res[k])

                            sum = res[k];

              }

              if(changed)

              {

                     temp = i;

                     i = j;

                     j = temp;

              }

              cout << i << " " << j << " " << sum <<endl;

       }

       return 0;

}

 

提交结果:

Source Code

Problem: 1207

 

User: uestcshe

Memory: 720K

 

Time: 16MS

Language: G++

 

Result: Accepted

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值