[POJ2503] Babelfish

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input
Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output
Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".
Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay
Sample Output
cat
eh
loops
Hint
Huge input and output,scanf and printf are recommended.
题意:输入英文单词及其对应的外文,然后输入若干个外语单词,输出他们的 英语翻译单词,

如果字典中不存在这个单词,则输出“eh”

题解:排序+二分搜索,只有输入不太好处理,其他都很简单,

当然也可用map做,但那不是这道题的本意

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int N=15;
const int M=1e5+10;
struct node{ char ml[N], fl[N]; }trs[M];
char word[N];
int cnt;

bool cmp( node a, node b ) {
	if( strcmp( a.fl, b.fl )<0 ) return 1;
    return 0;
}

int main() {
	for(;;) {
		char c=getchar();
		if( c=='\n' || c=='\r' ) break;
		int i=0; cnt++;
		for(;;) {
			trs[cnt].ml[i++]=c;
			c=getchar();
			if( c==32 ) break;
		}
		i=0;
		for(;;) {
			char c=getchar();
			if( c=='\n' || c=='\r' ) break;
			trs[cnt].fl[i++]=c;
		}
	}
	sort( trs+1, trs+cnt+1, cmp );
	while( ~scanf( "%s", word ) ) {
		int down=0, up=cnt, mid;
		bool flg=0;
		while( down<=up ) {
			mid=(down+up)>>1;
			if( strcmp( word, trs[mid].fl )==0 ) {
				flg=1; break;
			}
			else if( strcmp( trs[mid].fl, word )<0 )
				down=mid+1;
			else up=mid-1;
		}
		if( flg ) printf( "%s\n", trs[mid].ml );
		else printf( "eh\n" );
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值