UVa OJ 回文词(401)

 Palindromes 

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is apalindrome because it is the same when the string is read from left to right as when the string is read from right to left.


A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A"and "I" are their own reverses, and "3" and "E"are each others' reverses.


A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA"is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A", "T","O", and "Y" are all their own reverses.


A list of all valid characters and their reverses is as follows.


CharacterReverseCharacterReverseCharacterReverse
AAMMYY
B N Z5
C OO11
D P 2S
E3Q 3E
F R 4 
G S25Z
HHTT6 
IIUU7 
JLVV88
K WW9 
LJXX  


Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

Input 

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

Output 

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.


STRINGCRITERIA
" -- is not a palindrome."if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome."if the string is a palindrome and is not a mirrored string
" -- is a mirrored string."if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome."if the string is a palindrome and is a mirrored string

Note that the output line is to include the -'s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

Sample Input 

NOTAPALINDROME 
ISAPALINILAPASI 
2A3MEAS 
ATOYOTA

Sample Output 

NOTAPALINDROME -- is not a palindrome.
 
ISAPALINILAPASI -- is a regular palindrome.
 
2A3MEAS -- is a mirrored string.
 
ATOYOTA -- is a mirrored palindrome.





#include <stdio.h>
#include <stdlib.h>
#include<string.h>
char reback(char ch);
int ispa(char s[],int len);
int ismi(char s[],int len);
int main()
{
    char s[1000];
    int len;
    while(scanf("%s",s)!=EOF)
    {
        len=strlen(s);
        if(len==1)
        {
            if(s[0]!=reback(s[0]))
            printf("%s -- is a regular palindrome.\n\n",s);
            else printf("%s -- is a mirrored palindrome.\n\n",s);
        }
        else if(ispa(s,len)&&ismi(s,len))
        {
            printf("%s -- is a mirrored palindrome.\n\n",s);
        }
        else if(ispa(s,len))
        {
            printf("%s -- is a regular palindrome.\n\n",s);
        }
        else if(ismi(s,len))
        {
            printf("%s -- is a mirrored string.\n\n",s);
        }
        else
        {
            printf("%s -- is not a palindrome.\n\n",s);
        }
    }
    return 0;
}
char reback(char ch)
{
    switch(ch)
    {
        case 'A':return 'A';
        case 'E':return '3';
        case 'H':return 'H';
        case 'I':return 'I';
        case 'J':return 'L';
        case 'L':return 'J';
        case 'M':return 'M';
        case 'O':return 'O';
        case 'S':return '2';
        case 'T':return 'T';
        case 'U':return 'U';
        case 'V':return 'V';
        case 'W':return 'W';
        case 'X':return 'X';
        case 'Y':return 'Y';
        case 'Z':return '5';
        case '1':return '1';
        case '2':return 'S';
        case '3':return 'E';
        case '5':return 'Z';
        case '8':return '8';
        default:return ' ';
    }
}
int ispa(char s[],int len)
{
    int i;
    for(i=0;i<len/2;i++)
    {
        if(s[i]!=s[len-1-i])return 0;
    }
    return 1;
}
int ismi(char s[],int len)
{
    int i;
    for(i=0;i<len/2;i++)
    {
        if(reback(s[i])!=s[len-1-i])return 0;
    }
    return 1;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值