广西 2017 邀请赛 CS Course

题目描述

Little A has come to college and majored in Computer and Science.
Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.
Here is the problem:
You are giving n non-negative integers a1,a2,…,an, and some queries.
A query only contains a positive integer p, which means you are asked to answer the result of bit-operations (and, or, xor) of all the integers except ap.

输入

There are no more than 15 test cases.
Each test case begins with two positive integers n(2 ≤ n ≤ 105) and p(2 ≤ p ≤ 105) in a line, indicate the number of positive integers and the number of queries.
Then n non-negative integers a1,a2,…,an follows in a line, 0 ≤ ai ≤ 109 for each i in range [1,n].
After that there are q positive integers p1, p2, …,pq in q lines, 1 ≤ pi ≤ n for each i in range [1,q].

输出

For each query p, output three non-negative integers indicates the result of bit-operations(and, or,xor) of all non-negative integers except ap in a line.

样例输入

3 3
1 1 1
1
2
3

样例输出

1 1 0
1 1 0
1 1 0

题意

一个数n,一个数k,下一行有n个数,再下一行有k个操作。
每一个操作有一个数x,输出,除了x以外的其他的所有的数的且,或,抑或的值。
用4个数组来初始化这个长度为n的序列。
一个存正向的,第k个数之前所有的数的且值,另一个存从第n个数到第n-k个数的且值;
一个存正向的,第k个数之前所有的数的或值,另一个存从第n个数到第n-k个数的或值;
最后还有一个数存数组所有数的抑或值。(因为相同的数抑或两次没有影响。)
然后,读入一个x直接输出。

代码


#include <bits/stdc++.h>
 //这种思路也是一样的,就是把抑或也跟且、或做了相同的处理。
using namespace std;
int a[100000],b1[100000],b2[100000],c1[100000],c2[100000],d1[100000],d2[100000];
int main()
{
    int n,p,q,i;
    while(scanf("%d %d",&n,&q)!=EOF)
    {
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        b1[0] = a[0];
        c1[0] = a[0];
        d1[0] = a[0];
        b2[n-1] = a[n-1];
        c2[n-1] = a[n-1];
        d2[n-1] = a[n-1];
        for(i=1;i<n;i++)
        {
            b1[i] = b1[i-1]&a[i];
            c1[i] = c1[i-1]|a[i];
            d1[i] = d1[i-1]^a[i];
        }
        for(i=n-2;i>=0;i--)
        {
            b2[i] = b2[i+1]&a[i];
            c2[i] = c2[i+1]|a[i];
            d2[i] = d2[i+1]^a[i];
        }
        for(i=0;i<q;i++)
        {
            scanf("%d",&p);
            if(p==1)
                printf("%d %d %d\n",b2[1],c2[1],d2[1]);
            else if(p==n)
                printf("%d %d %d\n",b1[n-2],c1[n-2],d1[n-2]);
            else
                printf("%d %d %d\n",b1[p-2]&b2[p],c1[p-2]|c2[p],d1[p-2]^d2[p]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

渴鱼

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值