sgu 126 Boxes

39 篇文章 0 订阅
18 篇文章 0 订阅

126. Boxes

time limit per test: 0.5 sec.
memory limit per test: 4096 KB

There are two boxes. There are A balls in the first box, and B balls in the second box (0 < A + B < 2147483648). It is possible to move balls from one box to another. From one box into another one should move as many balls as the other box already contains. You have to determine, whether it is possible to move all balls into one box.

Input

The first line contains two integers A and B, delimited by space.

Output

First line should contain the number N - the number of moves which are required to move all balls into one box, or -1 if it is impossible.

Sample Input

Sample Output

2 6

Sample Output

2

#include<iostream>
#include<cstring>
#include<cstdio>
#include<set>
#include<algorithm>
#include<vector>
#include<cstdlib>
#include<map>

#define inf 0xfffffff
#define CLR(a,b) memset((a),(b),sizeof((a)))

using namespace std;
int const nMax = 40000;
typedef long long LL;
typedef pair<LL,LL> pij;


LL gcd(LL a,LL b){
    if(b==0)return a;
    else return gcd(b,a%b);
}
LL a,b;

int main()
{
    while(cin>>a>>b){
        if(a>b)swap(a,b);
        int ans=0;
        if(a==0){
            cout<<0<<endl;
            break;
        }
        if((a+b)&1){
            cout<<-1<<endl;
            break;
        }
        while(a){
            LL d=gcd(a,b);
            if((a+b)/d%2==1){
                cout<<-1<<endl;
                return 0;
            }
            a/=d;
            b/=d;
            b-=a;
            a+=a;
            ans++;
            if(a>b)swap(a,b);
        }
        cout<<ans<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值