hdu 1712 ACboy needs your help

ACboy needs your help

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 158   Accepted Submission(s) : 74
Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.
 

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.
 

Sample Input
  
  
2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output
  
  
3 4 6
 

Source
HDU 2007-Spring Programming Contest
 

题意:ACboy这学期有N门课程,他计划花最多M天去学习去学习这些课程,ACboy再第i天学习第j门课程的收益是不同的,求ACboy能获得的最大收益。

思路:分组背包,注意同一门课程之能选1次。

#include<stdio.h>
#include<string.h>
int wi[155][155];   //作用值
int vi[155][155];   //所花天数
int xx[111];
int n,m;
int f[3333];
int package()   //背包模版
{
    for(int i=0;i<=m;i++)
        f[i]=0;
    for(int j=0;j<n;j++)
    {
        for(int h=m;h>=0;h--)
        {
            for(int i=0;i<m;i++)
            {
                if(h-vi[j][i]>=0)
                    f[h]=f[h]>f[h-vi[j][i]]+wi[j][i]?f[h]:f[h-vi[j][i]]+wi[j][i];
            }
        }
    }
    return f[m];
}
int main()
{
    int i,j;
    int ans;
    while(scanf("%d%d",&n,&m)&&m&&n)
    {
        memset(vi,0,sizeof(vi));
        memset(wi,0,sizeof(wi));
        for(i=0;i<n;i++)
        {    
            for(j=0;j<m;j++)
            {
                vi[i][j]=j+1;
                scanf("%d",&wi[i][j]);
            }
        }
        ans=package();
        printf("%d\n",ans);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

程序员囧辉

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值