关闭

Cocoapods在OS X Yosemite上报错的解决方法

164人阅读 评论(0) 收藏 举报
分类:

今天升级了Mac OS X 10.10-Yosemite以后运行pod install遇到下面的错误: 

1
2
3
/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/fileutils.
rb:245:in 'mkdir': Permission denied - /Library/Ruby/Gems/2.0.0/extensions/universal
-darwin-14 (Errno::EACCES)

一番折腾后找到解决方案如下:

1. 分别执行下面命令卸载cocoapods和xcodeproj,如果你的机器上面有多个版本,选择All versions卸载 

1
2
3
$ sudo gem uninstall cocoapods
 
$ sudo gem uninstall xcodeproj

2. 分别执行下面命令安装xcodeproj和cocoapods 

1
2
3
$ sudo gem install xcodeproj
 
$ sudo gem install cocoapods

接下来尝试执行pod install,如果您还遇到下面的错误:

1
2
Error loading the plugin with path '/Library/Ruby/Gems/2.0.0/gems/cocoapods-plugins-0.3.1/lib/cocoapods_plugin.rb'.
Errno::EACCES - Permission denied - /Library/Ruby/Gems/2.0.0/extensions/universal-darwin-14

运行命令$ gem update --system即可。

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:47616次
    • 积分:1036
    • 等级:
    • 排名:千里之外
    • 原创:47篇
    • 转载:47篇
    • 译文:0篇
    • 评论:4条
    文章分类
    最新评论