hdu 1348 Wall (凸包模板)

21 篇文章 0 订阅
8 篇文章 0 订阅

题目链接:hdu 1348

Wall

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King’s castle. The King was so greedy, that he would not listen to his Architect’s proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.
Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King’s requirements.

这里写图片描述

The task is somewhat simplified by the fact, that the King’s castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle’s vertices in feet.

Input
The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King’s castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.

Next N lines describe coordinates of castle’s vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

Output
Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King’s requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Sample Input
1

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output
1628

题目稍微有点长。

题意是说一个国王给你一些点,这些点组成一个城堡,国王要求在这个多边形形状的城堡周围建起周长最小的城墙,并且城墙与城堡的距离处处不得小于L。

凸包模板水题。
用凸包找到可以包括所有点的最大多边形,算出这个多边形的周长再加上以题目中给的距离为半径的圆的周长即可。

#include <iostream>
#include <vector>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#define MAX 100005
#define M 10000010
#define MM 10005
#define INF -0x7f7f7f7f
#define PI acos(-1)

using namespace std;

struct point
{
    double x, y;

    point(){}

    point(double _x, double _y)
    {
        x = _x, y = _y;
    }

    point operator + (const point t)
    {
        return point(x + t.x, y + t.y);
    }

    point operator - (const point t)
    {
        return point(x - t.x, y - t.y);
    }

    point operator * (double a)
    {
        return point(x * a, y * a);
    }

    double operator * (const point t)
    {
        return x * t.y - t.x * y;
    }

    double len(const point t)
    {
        return sqrt((x - t.x) * (x - t.x) + (y - t.y) * (y - t.y));
    }
};

bool cp(point p1, point p2, point p0)
{
    return ((p1.x - p0.x) * (p2.y - p0.y) >= (p2.x - p0.x) * (p1.y - p0.y));
}

bool operator < (const point &p1, const point &p2)
{
    return p1.y < p2.y || (p1.y == p2.y && p1.x < p2.x);
}

point p[MAX];
point s[MAX];
int top;

int convex(int n)
{
    int i, len, k = 0, top = 1;

    sort(p, p + n);

    if(n == 0)  return 0;   s[0] = p[0];
    if(n == 1)  return 0;   s[1] = p[1];
    if(n == 2)  return 0;   s[2] = p[2];

    for(int i = 2; i < n; i++)
    {
        while(top && cp(p[i], s[top], s[top - 1]))  top--;
        s[++top] = p[i];
    }

    len = top;  s[++top] = p[n - 2];

    for(int i = n - 3; i >= 0; i--)
    {
        while(top && cp(p[i], s[top], s[top - 1]))  top--;
        s[++top] = p[i];
    }
    return top;
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int N, L;
        scanf("%d %d", &N, &L);
        for(int i = 0; i < N; i++)
        {
            scanf("%lf %lf", &p[i].x, &p[i].y);
        }

        int cnt = convex(N);
        double ans = 0;

        for(int i = 1; i < cnt; i++)
        {
            ans += s[i].len(s[i - 1]);
        }
        ans += s[0].len(s[cnt - 1]) + PI * L * 2;
        if(T > 0)
            printf("%.0lf\n\n", ans);
        else
            printf("%.0lf\n", ans);
    }
    return 0;
}

运行结果:
这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值