hdu 2389 Rain on your Parade (HK)

http://acm.hdu.edu.cn/showproblem.php?pid=2389

Rain on your Parade

Problem Description
You’re giving a party in the garden of your villa by the sea. The party is a huge success, and everyone is here. It’s a warm, sunny evening, and a soothing wind sends fresh, salty air from the sea. The evening is progressing just as you had imagined. It could be the perfect end of a beautiful day.
But nothing ever is perfect. One of your guests works in weather forecasting. He suddenly yells, “I know that breeze! It means its going to rain heavily in just a few minutes!” Your guests all wear their best dresses and really would not like to get wet, hence they stand terrified when hearing the bad news.
You have prepared a few umbrellas which can protect a few of your guests. The umbrellas are small, and since your guests are all slightly snobbish, no guest will share an umbrella with other guests. The umbrellas are spread across your (gigantic) garden, just like your guests. To complicate matters even more, some of your guests can’t run as fast as the others.
Can you help your guests so that as many as possible find an umbrella before it starts to pour? 

Given the positions and speeds of all your guests, the positions of the umbrellas, and the time until it starts to rain, find out how many of your guests can at most reach an umbrella. Two guests do not want to share an umbrella, however. 
Input
The input starts with a line containing a single integer, the number of test cases.
Each test case starts with a line containing the time t in minutes until it will start to rain (1 <=t <= 5). The next line contains the number of guests m (1 <= m <= 3000), followed by m lines containing x- and y-coordinates as well as the speed si in units per minute (1 <= s i <= 3000) of the guest as integers, separated by spaces. After the guests, a single line contains n (1 <= n <= 3000), the number of umbrellas, followed by n lines containing the integer coordinates of each umbrella, separated by a space.
The absolute value of all coordinates is less than 10000.
Output
For each test case, write a line containing “Scenario #i:”, where i is the number of the test case starting at 1. Then, write a single line that contains the number of guests that can at most reach an umbrella before it starts to rain. Terminate every test case with a blank line.
Sample Input
  
  
2 1 2 1 0 3 3 0 3 2 4 0 6 0 1 2 1 1 2 3 3 2 2 2 2 4 4
Sample Output
  
  
Scenario #1: 2 Scenario #2: 2
题意:给一些人和一些伞的坐标,然后每个人都有一定的速度,还有多少时间就会下雨,问最多能有多少人可以拿到伞。

这道题不是很理解,先把代码放到这儿,等会了再写

///#pragma comment (linker, "/STACK:102400000,102400000")

#include <iostream>
#include <queue>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <stack>
#include <vector>
#include <map>

using namespace std;

#define N 3350
#define INF 0xfffffff
#define PI acos (-1.0)
#define EPS 1e-8

struct node{int x, y, v;}p[N], um;

bool ok (node a, node b, int v)
{
    int len = (a.x-b.x)*(a.x-b.x) + (a.y-b.y)*(a.y-b.y);

    if (len > v*v) return false;
    return true;
}

struct Edge{int v, next;}edge[N*N];

int head[N], cnt, mx[N], my[N], dx[N], dy[N], nx, ny, d;
bool vis[N];

void addedge (int u, int v);
bool BFS ();
bool DFS (int u);
int karp ();

int main ()
{
    int T, t = 1;
    scanf ("%d", &T);
    while (T--)
    {
        int time;

        scanf ("%d %d", &time, &nx);
        memset (head, -1, sizeof (head));
        cnt = 0;

        for (int i=1; i<=nx; i++)
            scanf ("%d %d %d", &p[i].x, &p[i].y, &p[i].v);

        scanf ("%d", &ny);

        for (int i=1; i<=ny; i++)
        {
            scanf ("%d %d", &um.x, &um.y);

            for (int j=1; j<=nx; j++)
                if (ok (p[j], um, p[j].v*time))
                    addedge (j, i);
        }

        int ans = karp ();
        printf ("Scenario #%d:\n%d\n\n", t++, ans);
    }
    return 0;
}

void addedge (int u, int v)
{
    edge[cnt].v = v;
    edge[cnt].next = head[u];
    head[u] = cnt++;
}

bool BFS ()
{
    queue <int> que;
    d = INF;

    memset (dx, -1, sizeof (dx));
    memset (dy, -1, sizeof (dy));

    for (int i=1; i<=nx; i++)
    {
        if (!mx[i])
        {
            dx[i] = 0;
            que.push (i);
        }
    }

    while (que.size ())
    {
        int x = que.front(); que.pop ();
        if (dx[x] > d) break;

        for (int i=head[x]; i!=-1; i=edge[i].next)
        {
            int v = edge[i].v;

            if (dy[v] == -1)
            {
                dy[v] = dx[x] + 1;

                if (!my[v]) d = dy[v];

                else
                {
                    dx[ my[v] ] =dy[v] + 1;
                    que.push (my[v]);
                }
            }
        }
    }

    if (d == INF) return false;
    return true;
}

bool DFS (int u)
{
    for (int i=head[u]; i!=-1; i=edge[i].next)
    {
        int v = edge[i].v;

        if (!vis[v] && dx[u] == dy[v] - 1)
        {
            vis[v] = true;

            if (my[v] && dy[v] == d) continue;

            if (!my[v] || DFS (my[v]))
            {
                my[v] = u;
                mx[u] = v;
                return true;
            }
        }
    }
    return false;
}

int karp ()
{
    int ans = 0;
    memset (mx, false, sizeof (mx));
    memset (my, false, sizeof (my));

    while (BFS ())
    {
        memset (vis, false, sizeof (vis));
        for (int i=1; i<=nx; i++)
            if (!mx[i] && DFS (i))
            ans++;
    }
    return ans;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_大太阳_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值