1194 . Message Flood

Well, how do you feel about mobile phone? Your answer would probably be something like that “It’s so convenient and benefits people a lot”. However, if you ask Merlin this question on the New Year’s Eve, he will definitely answer “What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting messages to send! ”. Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What’s worse, Merlin has another long name list of senders that have sent message to him, and he doesn’t want to send another message to bother them (Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send messages, he needs to figure to how many friends are left to be sent. Please write a program to help him. 

Here is something that you should note. First, Merlin’s friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that’s why some message senders are even not included in his friend list.

Input

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n, m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings (the length of each will be less than 10), indicating the names of Merlin’s friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders.

 The input is terminated by n=0. 

Output

For each case, print one integer in one line which indicates the number of left friends he must send. 

Sample Input
 Copy sample input to clipboard
5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0
Sample Output
3

这道题有一个特点是,重复的名字也算同一个,所以用set再合适不过了。
第一次使用set库呢,有好多函数都要记得。
// Problem#: 1194
// Submission#: 4948878
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include<iostream>
#include<set>
#include<string>
using namespace std;
int main()
{
   
    string str;
    int m,n;
    while(cin>>n&&n)
    {
        set<string> myset;
        cin>>m;
       
        for(int i=0;i<n;i++)
        {
            cin>>str;
            for(int j=0;j<str.length();j++)
                str[j]=tolower(str[j]);//将输入的字符大写转小写。使用的是函数tolower()。
            myset.insert(str);//插入转为小写的str
        }
        for(int i=0;i<m;i++)
        {
            cin>>str;
            for(int j=0;j<str.length();j++)//注意这里字符串长度要使用str.length()而不是.size().
                str[j]=tolower(str[j]);
            set<string>::iterator itor=myset.find(str);//这里使用stl中的迭代器,大概就是指针find用来定位str在myset里的位置。
            if(itor!=myset.end())//如果myset里有这个str,就把该str删掉。
                myset.erase(str);
        }
        cout<<myset.size()<<endl;//最后输出myset的大小即可,(重复的都已被删掉)
    }
    return 0;
}                                 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值