POJ 3261 Milk Patterns 最长出现k次的子串长度(后缀数组)

Milk Patterns

Time Limit: 5000MS Memory Limit: 65536K
Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can’t predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns – 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers: N and K
Lines 2..N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.
Output

Line 1: One integer, the length of the longest pattern which occurs at least K times
Sample Input

8 2
1
2
3
2
3
2
3
1
Sample Output

4

题意:求最长的出现k次的子串的长度

思路:先二分答案(即二分子串的长度),把题目变成判定性问题,然后将后缀分成若干组。其中每组的后缀之间的height值都不小于mid。也就是找连续的大于mid的长度的个数,多于k-1就可以返回1,不然返回0。判断有没有一个组的后缀个数不小于k。如果有,那么存在k个相同的子串满足条件,否则不存在。时间复杂度为O(nlogn)。

#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <algorithm>  
#define LL long long
#define N 20005
using namespace std;

int t1[N], t2[N], c[N], sa[N];  
int rank[N], height[N], s[N]; 
int ans, n, m, mx;

//sa:字典序中排第i位的起始位置 
//rank:就是str第i个位置的后缀是在字典序排第几  
//height:字典序排i和i-1的后缀的最长公共前缀  

void build_sa(int m){
    int *x = t1, *y = t2;
    for(int i=0; i<m; i++) c[i] = 0;
    for(int i=0; i<n; i++) c[x[i] = s[i]]++;
    for(int i=1; i<m; i++) c[i] += c[i-1];
    for(int i=n-1; i>=0; i--) sa[--c[x[i]]] = i;
    for(int k=1; k<=n; k = k<<1){
        int p = 0;
        for(int i=n-k; i<n; i++) y[p++] = i; 
        for(int i=0; i<n; i++) if(sa[i] >= k) y[p++] = sa[i]-k;
        for(int i=0; i<m; i++) c[i] = 0;
        for(int i=0; i<n; i++) c[x[y[i]]]++;
        for(int i=0; i<m; i++) c[i] += c[i-1];
        for(int i=n-1; i>=0; i--) sa[--c[x[y[i]]]] = y[i];
        swap(x,y);
        p = 1; x[sa[0]] = 0;
        for(int i=1; i<n; i++)
            x[sa[i]] = y[sa[i-1]] == y[sa[i]] && y[sa[i-1]+k] == y[sa[i]+k] ? p-1 : p++;
        if(p >= n) break;
        m = p; 
    }
}

void build_height(int *r, int n){
    int k=0, j;  
    for(int i=0; i<n; i++)  rank[sa[i]] = i;//如果在原串后面加了一个极小的字符(某些题目需要)
    //就应该for(int i=1; i<=n; i++)//因为以这个极小字符开头的后缀串一定是最小的,也就是s[0]
    //我们0~n-1,n个后缀串也就变成了0~n,n个,所以for 1~n(网上大多数代码并没有解释这一点) 
    for(int i=0; i<n; height[rank[i++]] = k)
        for(k ? k--:0, j = sa[rank[i]-1]; r[i+k] == r[j+k]; k++);
}  


int check(int k){  
    int i, mx, minn = sa[1], cnt = 1;//最开始一个数一组 
    for(int i=2; i<=n; i++){  
        if(height[i] >= k){//首先最长公共前缀肯定要大于现在枚举的长度  
            cnt++;//统计连续且满足条件的个数  
        }  
        else{  
            cnt = 1;//如果不行,那么重新分组  
        }  
        if(cnt >= m)//次数超过了,那么这个k长度下是可行的  
            return 1;  
    }  
    return 0;  
}  


int main(){
    while( (~scanf("%d%d", &n, &m)) ){  
        ans = mx = 0;  
        for(int i=0; i<=n-1; i++){  
            scanf("%d", &s[i]);  
            mx = max(mx, s[i]);
        }
        //s[n] = 0;
        build_sa( mx+1 );//要比最大值大1 
        build_height(s, n);
        int l = 1, r = n;
        while(l <= r){//二分长度 
            int mid = (l + r) >> 1;  
            if( check(mid) ){  
                ans = mid;  
                l = mid + 1;  
            }
            else r = mid - 1;
        }
        printf("%d\n", ans);  
    }
    return 0;  
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值