hdu 6201

transaction transaction transaction

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 870 Accepted Submission(s): 425

Problem Description
Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named “the Man Who Changed China”. Of course, Kelukin wouldn’t miss this chance to make money, but he doesn’t have this book. So he has to choose two city to buy and sell.
As we know, the price of this book was different in each city. It is ai yuan in it city. Kelukin will take taxi, whose price is 1yuan per km and this fare cannot be ignored.
There are n−1 roads connecting n cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.

Input
The first line contains an integer T (1≤T≤10) , the number of test cases.
For each test case:
first line contains an integer n (2≤n≤100000) means the number of cities;
second line contains n numbers, the ith number means the prices in ith city; (1≤Price≤10000)
then follows n−1 lines, each contains three numbers x, y and z which means there exists a road between x and y, the distance is zkm (1≤z≤1000).

Output
For each test case, output a single number in a line: the maximum money he can get.

Sample Input
1
4
10 40 15 30
1 2 30
1 3 2
3 4 10

Sample Output
8

Source
2017 ACM/ICPC Asia Regional Shenyang Online

学习了一个Dp思路

#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <string.h>
#define LL long long
using namespace std;
int price[110000];
int dp[3*110000];
struct node
{
    int x,y,w;
}e[210000];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int k = 0;
        memset(price,0,sizeof(price));
        for(int i =1; i <= n; i++)
        {
            scanf("%d",&price[i]);
        }
        for(int i = 1; i < n; i++)
        {
            scanf("%d%d%d",&e[k].x,&e[k].y,&e[k].w);
            k++;
            e[k].x = e[k-1].y;
            e[k].y = e[k-1].x;
            e[k].w = e[k-1].w;
            k++;
        }
        memset(dp,0,sizeof(dp));
        for(int i = 0; i < k; i++)
        {
            dp[e[i].y] = max(dp[e[i].y],dp[e[i].x]-price[e[i].x]-e[i].w+price[e[i].y]);
        }
        int maxx = dp[1];
        for(int i = 1; i <= n; i++)
        {
            printf("%d ",dp[i]);
        }
        printf("\n");
        for(int i = 2; i <= n; i++)
        {
            maxx = max(dp[i],maxx);
        }
        printf("%d\n",maxx);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值