hdu 4027 Can you answer these queries?

Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output
Case #1:
19
7
6

Source
The 36th ACM/ICPC Asia Regional Shanghai Site —— Online Contest

给你一串序列 你可以对它进行两种操作 第一种是对从x到y的数变为变为原来数的平方,第二种是查询从x到y的和 因为最大数就是long long 所以这里我们会发现每个数最多开根号6 7 次,所以我们可以判断某个区间是不是都是1,如果是我们则不用更新直接返回。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
#define LL long long
LL a[110000];
LL tree[4*110000];
void build(int p,int l,int r)
{
    if(l == r)
    {
        tree[p] = a[l];
        return ;
    }
    int mid = (l + r)>>1;
    build(p*2,l,mid);
    build(p*2+1,mid+1,r);
    tree[p] = tree[p*2] + tree[p*2+1];
}
void update(int p,int l,int r,int x, int y)
{
    if(l == r)
    {
        tree[p] = sqrt(tree[p] * 1.0);
        return ;
    }
    if(l >= x && r <= y && tree[p] == r-l+1)
    {
        return ;
    }
    int mid = (l + r) >> 1;
    if(x <= mid)
    {
        update(p*2,l,mid,x,y);
    }
    if(y > mid)
    {
        update(p*2+1,mid+1,r,x,y);
    }
    tree[p] = tree[p*2] + tree[p*2+1];
}
LL query(int p, int l, int r, int x, int y)
{
    if(l>=x && r<=y)
    {
        return tree[p];
    }
    int mid = (l + r) >> 1;
    if(y <= mid)
    {
        return query(p*2, l, mid, x, y);
    }
    if(x > mid)
    {
        return query(p*2+1, mid+1, r, x, y);
    }
    return query(p*2, l, mid, x, mid) + query(p*2+1, mid+1, r, mid+1, y);
}
int main()
{
    LL n;
    int k = 0;
    while(~scanf("%lld",&n))
    {
        k++;
        for(int i = 1; i <= n; i++)
        {
            scanf("%lld",&a[i]);
        }
        build(1,1,n);
        int q;
        scanf("%d",&q);
        printf("Case #%d:\n",k);
        for(int  i = 0; i < q; i++)
        {
            int temp,x,y;
            scanf("%d%d%d",&temp,&x,&y);
            if(x > y) swap(x,y);
            if(temp == 0)
            {
                update(1,1,n,x,y);
            }
            else
            {
                LL ans = query(1,1,n,x,y);
                printf("%lld\n",ans);
            }
        }
        printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值