hdu 4081 Qin Shi Huang's National Road System

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China —- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty —- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself “Qin Shi Huang” because “Shi Huang” means “the first emperor” in Chinese.

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people’s life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible —- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.
Input
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.
Output
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.
Sample Input
2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40
Sample Output
65.00
70.00

题意:有N个城市,每个城市都有一个人口,现在要在这N个城市之间修路,使任意两个城市可以联通,现在可以不费任何花费修建一条边(Just one),让你求A/B的最大值,A是这条边连接的两个城市的人口和,B是修建所有路所需的花费。

做法:先求最小生成树,然后暴力枚举每一条边,如果这条边不在最小生成树里,那就用这条边去替换最小生成树中连接这条边的两个城市的路径中最长的那条边,如果在最小生成树里,就之间使这条边的花费为0,然后维护出一个最大值。 做法基本上是求最小生成树。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#define INF 999999999
#define LL long long
#define maxn 1100
double max(double a,double b)
{
    return a>b?a:b;
}
using namespace std;
double edge[maxn][maxn];
double lowcost[maxn];
bool vis[maxn];
bool used[maxn][maxn];
int pre[maxn];
double  Max[maxn][maxn];
struct node
{
    double x,y,w;
}a[maxn];
int n;
double suml;
void prime(int num)
{
    vis[num] = 1;
    pre[num] = -1;
    suml = 0;
    for(int i = 1; i <= n; i++)
    {
        if(i == num) continue;
        lowcost[i] = edge[i][num];
        pre[i] = num;
    }
    for(int i = 1; i < n; i++)
    {
        double minn = INF;
        int temp;
        for(int j = 1; j <= n; j++)
        {
            if(vis[j] == 0 && lowcost[j] < minn)
            {
                minn = lowcost[j];
                temp = j;
            }
        }
        vis[temp] = 1;
        used[temp][pre[temp]] = used[pre[temp]][temp]= 1;
        suml += minn;
        for(int j = 1; j <= n; j++)
        {
            if(vis[j] == 1 && j!= temp)
            {
                Max[j][temp] = Max[temp][j] = max(lowcost[temp],Max[j][pre[temp]]);
            }
            if(vis[j] == 0 && lowcost[j] > edge[j][temp])
            {
                lowcost[j] = edge[j][temp];
                pre[j] = temp;
            }
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(vis,0,sizeof(vis));
        memset(used,0,sizeof(used));
        memset(Max,0,sizeof(Max));
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                edge[i][j] = INF;
            }
        }
        for(int i = 1; i <= n; i++)
        {
            scanf("%lf%lf%lf",&a[i].x,&a[i].y,&a[i].w);
        }
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                if(i == j) continue;
                edge[i][j] = sqrt((a[i].x-a[j].x)*(a[i].x-a[j].x) + (a[i].y-a[j].y)*(a[i].y-a[j].y));
            }
        }
        prime(1);
        double maxx = -1;
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= n; j++)
            {
                if(edge[i][j] != INF)
                {
                    if(used[i][j] == 0)
                    {
                        double temp = (a[i].w+a[j].w)/(suml-Max[i][j]);
                        maxx = max(maxx,temp);
                    }
                    if(used[i][j] == 1)
                    {
                        double temp = (a[i].w+a[j].w)/(suml-edge[i][j]);
                        maxx = max(maxx,temp);
                    }
                }
            }
        }
        printf("%.2lf\n",maxx);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值