hdu 2473 Junk-Mail Filter

Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.
Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.
Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.
Sample Input
5 6
M 0 1
M 1 2
M 1 3
S 1
M 1 2
S 3

3 1
M 1 2

0 0
Sample Output
Case #1: 3
Case #2: 2

题意:给你n封邮件,它们的编号是0~n-1, 然后给你两种操作,一种是连接两封邮件(连接关系是间接的),另一种是从已有的连接中删除一一封邮件并删除它的关系,使之成为一个孤立的邮件,求最后有几个集合。

我们很容易想到并查集,但是普通的并查集又解决不了删点的问题,所以我们这里采用设立虚父节点的方法,不在是本身的父节点是自己,这样在删除时只需要为要删除的点设立一个新的父节点就好了。

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <string.h>
#define maxn 1100000
using namespace std;
int n,m;
int pre[4*maxn];
bool vis[4*maxn];
int ca = 1;
int findroot(int num)
{
    int temp = num;
    while(pre[num] != num)
    {
        num = pre[num];
    }
    while(pre[temp] != num)
    {
        int j = pre[temp];
        pre[temp] = num;
        temp = j;
    }
    return pre[num];
}
int main()
{
    while(scanf("%d%d",&n,&m) && m+n>0)
    {
        memset(vis,0,sizeof(vis));
        for(int i = 0; i < n; i++)
        {
            pre[i] = i+n;
        }
        for(int i = n; i <= 2*n+m; i++)
        {
            pre[i] = i;
        }
        int p = 2*n;
       for(int i = 0; i < m; i++)
       {
           char s;
           int a,b;
           scanf(" %c",&s);
           if(s == 'M')
           {
               scanf("%d%d",&a,&b);
               int roota = findroot(a);
               int rootb = findroot(b);
               if(roota != rootb)
               {
                   pre[roota] = rootb;
               }
           }
           if(s == 'S')
           {
               scanf("%d",&a);
               pre[a] = p++;
           }
       }
       int cnt = 0;
       for(int i = 0; i < n; i++)
       {
           int temp = findroot(i);
           if(vis[temp] == 0)
           {
               cnt++;
               vis[temp] = 1;
           }
       }
       printf("Case #%d: %d\n",ca++,cnt);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值