数据结构上机测试4.1:二叉树的遍历与应用1

数据结构上机测试4.1:二叉树的遍历与应用1
Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic
Problem Description

输入二叉树的先序遍历序列和中序遍历序列,输出该二叉树的后序遍历序列。
Input

第一行输入二叉树的先序遍历序列;
第二行输入二叉树的中序遍历序列。
Output

输出该二叉树的后序遍历序列。
Example Input

ABDCEF
BDAECF
Example Output

DBEFCA
Hint

Author

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
    int data;
    struct node *l, *r;
};
struct node *creat(int n, char *a, char *b)//二叉树的重建与后续遍历输出
{
    int i;
    struct node *root;
    if(n == 0) return NULL;
    root = (struct node *) malloc (sizeof(struct node));
    root -> data = a[0];//找到根节点,根节点为str1(先序序列)的第一个
    for(i = 0; i < n; i++)
    {
        if(b[i] == a[0])
            break;
    }
    root -> l = creat(i, a+1, b);//(左子树的长度,左子树在str1中开始位置的地址,左子树在str2中开始位置的地址)
    root -> r = creat(n - 1 - i, a+i+1, b+i+1);//(右子树的长度,右子树在str1中开始位置的地址,右子树在str2中开始位置的地址)
    printf("%c", root -> data);//后序遍历输出
    return root;
};
int main()
{
    char a[11111];
    char b[11111];
    int n;
    scanf("%s%s", a, b);
    n = strlen(a);
    creat(n, a, b);
    printf("\n");
    return 0;
}

哇,说实话,二叉树搞得我头皮发麻,很难受,很气。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值