关闭

[转][Android]Android运行的错误提示--整理

标签: androideclipse
71人阅读 评论(0) 收藏 举报
分类:

①打开eclipse报错:发现了以元素 'd:skin' 开头的无效内容。此处不应含有子元素。

【错误】打开eclipse报错:发现了以元素 ‘d:skin’ 开头的无效内容。此处不应含有子元素。 
【具体报错信息】 
Error parsing D:\android-sdks\system-images\android-22\android-wear\armeabi-v7a\devices.xml 
cvc-complex-type.2.4.d: 发现了以元素 ‘d:skin’ 开头的无效内容。此处不应含有子元素。 
Error: Error parsing D:\android-sdks\system-images\android-22\android-wear\x86\devices.xml 
cvc-complex-type.2.4.d: 发现了以元素 ‘d:skin’ 开头的无效内容。此处不应含有子元素。 
【解决方法】 
方法1: 
在SDK Manager里删除Android-wear相关的image 
方法2: 
进入sdk目录下,把..\android-sdk\system-images\android-22\android-wear\armeabi-v7a\devices.xml和..\android-sdk\system-images\android-22\android-wear\x86\devices.xml文件删除,再把sdk里面..\android-sdk\tools\lib\下的devices.xml拷贝到上述两个文件夹里,重启eclipse即可
原文:http://www.bubuko.com/infodetail-981506.html

②Error: Error parsing D:\android-sdk-windows\sdk\system-images\android-22\android-wear\x86\devices.xm


我是Android初学者,自己上网下了一个“adt-bundle-windows-x86-20140702.rar”已经集成Android开发的eclipse,

然后,我使用SDK Manager把我需要的开发支持包下载了一些,

但是在我学习创建AVD模拟器是出问题了,

下面一直报错的错误信息

Error: Error parsing D:\android-sdk-windows\sdk\system-images\android-22\android-wear\armeabi-v7a\devices.xml

Error: Error parsing D:\android-sdk-windows\sdk\system-images\android-22\android-wear\x86\devices.xml

”,

这个问题很是烦人,尽管他并不影响程序模拟器的运行,但是看着有错误,总是感觉不爽!

我上网找了很多资料,大家给的资料都是比较多、乱、杂!

我这里总结一下,可能不是很准确,但是基本可以解决问题:

原因:就是现在你下载比较新的API22:Android5.1 || Android M,这些东西在一些小小的设置兼容配置方面还是有点问题

解决办法:直接把“D:\android-sdk-windows\sdk\tools\lib\devices.xml”(这是我的路径),也就是你sdk文件夹下\tools文件夹\lib文件夹\devices.xml文件   -----》》》   复制替换你上面你对应处错误的文件夹下的devices.xml文件!

最后重启eclipse,点击ADV Manager创建模拟器就不会报错了!

原文:http://blog.csdn.net/u013085291/article/details/46505451


由于最近通过SDK-Manager更新了build-tools,当要用到dx.jar这个包时,自动调用最新build-tools中dx.jar,但是运行android项目时Console却提示:

Failed to load C:\Program Files (x86)\Android\android-sdk\build-tools\26.0.0-preview\lib\dx.jar

Unable to build: the file dx.jar was not loaded from the SDK folder

根据提示的意思应该就是这个dx.jar包有问题(可能是兼容性问题吧,越新问题越多QAQ,蓝瘦)


解决步骤:

(1)找到你Android的SDK安装目录C:\Program Files (x86)\Android\android-sdk,进入build-tools文件夹

(2)发现还有很多其他版本的build-tools,而且版本都是顺序排列的,我们就选择倒数第二个(最新版上面那个文件夹),打开进入lib文件夹



(3)发现里面有dx.jar包,复制粘贴到最新版build-tools存放dx.jar包的目录下,替换掉原来的dx.jar包(C:\Program Files (x86)\Android\android-sdk\build-tools\26.0.0-preview\lib\dx.jar)

(4)完成,再次启动Android项目,问题解决!


有没有可以在不替换这个包的前提下解决呢?毕竟别人自带的包,是吧!

如果有更好的方法或者建议,请提出来!谢谢!

原文:http://blog.csdn.net/qq_32224139/article/details/69525946

            ④Unable to resolve target 'Google'Inc.:Google APIs:8'

当从网上下载一个Android项目打开的时候,有可能就会报错:Unable to resolve target 'Google Inc.:Google APIs:8'

这是由于项目的target使用的是Google的API,但我们的Eclipse中并没有装相应的SDK包,系统查找不到自然就报错了,自己也遇到过这个问题,现在把解决方法写出来给一些遇到同样问题的朋友一点帮助吧!

首先我要讲的第一个方法是网上大部分人说的解决办法

(一)在项目里面找到project.properties打开,将里面的target=Google Inc.:Google APIs:8这项改成自己的版本,比如说我的是android-20,我就改成target=android-20,这样就不会报错了。


但如果你这个项目里面有使用到Google的API例如Google map,那么用第一个方法之后项目的其他地方将会报错,提示找不到对应的类,所以在这里给出了我自己想到的一个解决办法:

(二)这个方法不需要修改第一个方法里面的版本,遇到Unable to resolve target 'Google Inc.:Google APIs:8'的报错,直接到SDK Manager里面下载相应的Google APIs就可以了,如图

wKioL1PHqD-zO0aKAAL7kWy50R4546.jpg

如果SDK无法成功下载,可以到http://8432499.blog.51cto.com/8422499/1438185这个链接里看“使用SDK Manager.exe无法进行更新”的解决办法。

这样更新完相应的Google APIs包问题就解决了。

本文出自 “蜗牛旅途” 博客,请务必保留此出处http://8432499.blog.51cto.com/8422499/1439638


⑤其他内容

Android SDK Manager和AVD Manager使用:http://blog.csdn.net/yuan2053/article/details/62895948

最新鲜最详细的Android SDK下载安装及配置教程:http://blog.csdn.net/dr_neo/article/details/49870587(Android SDK变量自己写,不要直接复制原文)

Eclipse中离线安装ADT插件详细教程:http://blog.csdn.net/dr_neo/article/details/46941859

国内Android SDK文件包下载地址:http://www.androiddevtools.cn/#


0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:457次
    • 积分:61
    • 等级:
    • 排名:千里之外
    • 原创:3篇
    • 转载:0篇
    • 译文:0篇
    • 评论:0条
    文章分类
    文章存档