文章标题 POJ 3272 : Monthly Expense (二分)

Monthly Expense

Description
Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.
FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.
FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.
Input
Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500
Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.
题意:john有n天的花费,然后他想将这些天的花费划分成m个月,每个月的花费为这些天花费的总数,这些天是连续的,现在他想知道划分成这m个月后,要使得这些月的最大花费要最小。
分析:可以知道,最小花费肯定在每天话费的最大值maxn和这些天的总花费sum之间,所以只需要二分这个区间就行,计算当前mid时,这n天能分成的月数count,如果count

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue> 
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
int n,m;
int money[100005];
int main ()
{
    while (scanf ("%d%d",&n,&m)!=EOF){
        int maxn=0;
        long long sum=0;
        for (int i=0;i<n;i++){
            scanf ("%d",&money[i]);
            maxn = max(maxn,money[i]);
//求每天话费的最大值
            sum+=money[i];
//求总花费
        }
        long long lo =maxn,hi=sum;
        long long mid;
        while (lo<hi){
            long long tmp=0;
            long long count=0;//比lo+hi>>2大的数量 
            mid = (lo+hi)/2;
            for (int i=0;i<n;i++){
                tmp+=money[i];
/
                if (tmp>mid){
                    count++;tmp=money[i];
                }
            }
            if (count<m){//小于分组数量说明当前的值大了 
                hi=mid;
            } 
            else lo=mid+1;
        }
        printf ("%lld\n",lo);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值