3D dungeon

3D dungeon

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 
输入
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
输出
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
样例输入
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
样例输出
Escaped in 11 minute(s).
Trapped!
简单的bfs,把二维变三维就行
#include<stdio.h>
#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
char a[100][100][100];
int b[100][100][1000];
int l,n,m;
int d[6][3]= {{0,1,0},{0,0,1},{0,-1,0},{0,0,-1},{-1,0,0},{1,0,0}};六个方向
struct node
{
    int x,y,z,bu;
} now,haha;
int bfs(int x1,int y1,int z1,int step)
{
    queue<node>q;
    now.x=x1;
    now.y=y1;
    now.z=z1;
    b[x1][y1][z1]=1;
    now.bu=step;
    q.push(now);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        for(int i=0; i<6; i++)
        {
            haha.x=now.x+d[i][0];
            haha.y=now.y+d[i][1];
            haha.z=now.z+d[i][2];
            if(haha.x>=0&&haha.x<l&&haha.y>=0&&haha.y<n&&haha.z>=0&&haha.z<m&&b[haha.x][haha.y][haha.z]==0&&a[haha.x][haha.y][haha.z]!='#')
            {
                haha.bu=now.bu+1;
                if(a[haha.x][haha.y][haha.z]=='E')
                {
                    return haha.bu;
                }
                b[haha.x][haha.y][haha.z]=1;
                q.push(haha);
            }
        }
    }
    return -1;
}
int main()
{
    while(scanf("%d%d%d",&l,&n,&m)!=-1)
    {
        if(l==0&&n==0&&m==0)
        {
            break;
        }
        memset(b,0,sizeof(b));
        int we,ni,ha;
        for(int i=0; i<l; i++)
        {
            for(int j=0; j<n; j++)
            {
                for(int k=0; k<m; k++)
                {
                    cin>>a[i][j][k];
                    if(a[i][j][k]=='S')
                    {
                        we=i;
                        ni=j;
                        ha=k;
                    }
                }
            }
        }
        int f;
        f=bfs(we,ni,ha,0);
        if(f==-1)
        {
            printf("Trapped!\n");

        }
        else
        {
            printf("Escaped in %d minute(s).\n",f);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值