杭电1075 What Are You Talking About

5 篇文章 0 订阅
2 篇文章 0 订阅
/*

What Are You Talking About
Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 19289    Accepted Submission(s): 6313


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

Output
In this problem, you have to output the translation of the history book.
 

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END

 

Sample Output

hello, i'm from mars.
i like earth!

Hint

Huge input, scanf is recommended.
 

 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:  1251 1800 1671 1247 1298 
 
*/
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
typedef struct Trie_node//要记得是typedef struct 
{
	int count;//统计单词前缀出现的次数 
	struct Trie_node* next[26];//指向各个子树的指针 
	bool exist;//标记该节点处是否构成单词 
	char trans[11];//翻译 
}TrieNode,*Trie;
Trie createTrieNode()
{
	TrieNode* node=(TrieNode *)malloc(sizeof(TrieNode));
	node->count=0;
	node->exist=false;
	memset(node->next,0,sizeof(node->next));//初始化为空指针 
	return node;
}
void Trie_insert(Trie root,char *word,char *trans)
{
	Trie node=root;
	char *p=word;
	int id;
	while(*p)
	{
		id=*p-'a';
		if(node->next[id]==NULL)
		{
			node->next[id]=createTrieNode();
		}
		node=node->next[id];
		p++;
		node->count += 1;//+=符号不能分开 
	}
	node->exist=true;//单词结束的地方 标记 此处可以构成一个单词 
	strcpy(node->trans,trans);
}
char* Trie_search(Trie root,char* word)
{
	Trie node=root;
	char *p=word;
	int id;
	while(*p)
	{
		id=*p-'a';
		node=node->next[id];
		p++;
		if(node==NULL)
		return 0;
	}
	if(node->exist)
	return node->trans;//查找成功 
	else
	return NULL;//查找失败 
}
int main()
{
	Trie root=createTrieNode();//初始化字典的根节点 
	char str1[3003],str2[3003],str[3003],*p;
	int i,k;
	scanf("%s",str1);
	while(~scanf("%s",str1)&&strcmp(str1,"END")!=0)//scanf函数的而返回值有问题
	{
		scanf("%s",str2);
		Trie_insert(root,str2,str1);
	}
	getchar();
	gets(str1);
	k=0;
	while(gets(str1))
	{
		if(strcmp(str1,"END")==0)
		break;
		for(i=0;str1[i]!='\0';i++)
		{
			if(str1[i]>='a'&&str1[i]<='z')
			{
				str[k++]=str1[i];
			}
			else
			{
				str[k]='\0';
				p=Trie_search(root,str);
				if(p)
				printf("%s",p);
				else
				printf("%s",str);
				k=0;
				printf("%c",str1[i]);
			}
		}
		printf("\n");
	} 
	return 0;
}

这是我第一次接触字典树 代码几乎都是照搬的。。 贵在理解吧

下面注上一个博客地址 我是从这个博客上学习的 非常感谢这位大神  http://blog.csdn.net/hackbuteer1/article/details/7964147

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值