POJ 3259 Wormholes

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 25690 Accepted: 9228

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  Tseconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

题目大意:虫洞问题,现在有n个点,m条边,代表现在可以走的通路,比如从a到b和从b到a需要花费c时间,现在在地上出现了w个虫洞,虫洞的意义就是你从a到b话费的时间是-c(时间倒流,并且虫洞是单向的),现在问你从某个点开始走,能回到从前

解题思路:其实给出了坐标,这个时候就可以构成一张图,然后将回到从前理解为是否会出现负权环,用bellman-ford就可以解出了

参考:http://blog.csdn.net/wangjian8006/article/details/7872003

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;
const int INF = 0x7fffffff;
const int maxn = 510;
const int maxm = 2500 + 200 + 10;
int gn, gm;
int gf, gw;
//Accepted	1320K	172MS	G++	2043B	2013-08-28 21:44:21
struct Edge {
    int from, to, dist;
};

vector<int> g[maxn];
vector<Edge> edges;
bool inq[maxn];
int d[maxn];
int p[maxn];
int cnt[maxn];

void addedge(int from, int to, int dist) {
    edges.push_back((Edge){from, to, dist});
    int m = edges.size();
    g[from].push_back(m-1);
}

bool negativeCycle(int s) {
    int i;
    queue<int> Q;
    memset(inq, 0, sizeof(inq));
    memset(cnt, 0, sizeof(cnt));
    for(i = 1; i <= gn; i++) {//图可能不连通.
        d[i] = 0;
        inq[i] = true;
        Q.push(i);
    }
    while(!Q.empty()) {
        int u = Q.front();
        Q.pop();
        inq[u] = false;
        for(i = 0; i < (int)g[u].size(); i++) {
            Edge& e = edges[g[u][i]];
            if(d[e.to] > d[u] + e.dist && d[u] != INF) {
                d[e.to] = d[u] + e.dist;
                p[e.to] = g[u][i];
                if(!inq[e.to]) {
                    Q.push(e.to);
                    inq[e.to] = true;
                    if(++cnt[e.to] > gn) {
                        return true;
                    }
                }
            }
        }
    }
    return false;
}

void init() {
    int i;
    for(i = 1; i <= gn; i++) {
        g[i].clear();
    }
}

int main()
{
    int i, x, y, w;
    scanf("%d", &gf);
    while(gf--) {
        scanf("%d%d%d", &gn, &gm, &gw);
        init();
        for(i = 1; i <= gm; i++) {
            scanf("%d%d%d", &x, &y, &w);
            addedge(x, y, w);
            addedge(y, x, w);
        }
        for(i = 1; i <= gw; i++) {
            scanf("%d%d%d", &x, &y, &w);
            addedge(x, y, -w);
        }
        int res = negativeCycle(1);
        if(res) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
/**
4
6 5 2
1 2 2
1 3 4
2 3 1
4 5 3
5 6 4
3 1 3
6 4 8
YES
**/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值