杭电ACM 1020 Encoding java解析

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34681    Accepted Submission(s): 15377


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
  
  
2 ABC ABBCCC
 

Sample Output
  
  
ABC

A2B3C

解题思路整理:对字符串进行遍历,如果当前的字符与前面的字符相同的话那么我加1记录其个数,如果不相同的时候,排除只有1个的情况,只有在字符重复个数大于1

的时候那么认为是有多个在一起,这是将字符串拼接组成新的串继续下一步操作。

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		int count = scanner.nextInt();
		int i = 0, countNum = 0, j = 0, j2 = 0;
		String str ;
		String str2 = "";
		char sCopy = 0;
		List<String> list = new ArrayList<String>();
		while(i < count)
		{
			str = scanner.next();
			
			sCopy = 0;
			j = 0;
			str2 = "";
			countNum = 0;
			
			while(j < str.length())
			{
				if(sCopy != str.charAt(j))
				{
					if(countNum > 1)
					{
						str2 = str2 + countNum + sCopy;
					}
					else if(j != 0)
						str2 = str2 + sCopy;
					
					countNum = 0;
					sCopy = str.charAt(j);
				}
				
				if(sCopy == str.charAt(j))
				{
					countNum++;
				}
				j++;
				if(j == str.length())
				{
					if(countNum > 1)
					{
						str2 = str2 + countNum + sCopy;
					}
					else if(j != 0)
						str2 = str2 + sCopy;
					list.add(str2);
				}
			}
			i++;
		}
		for(i = 0; i < count; i++)
		{
			System.out.println(list.get(i));
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值