关闭

TCP/IP网络配置实验

264人阅读 评论(0) 收藏 举报

很久没有写博客了,最近在找工作,刚好看到本科的路由协议设计,传上来给大家看看



一、实验拓扑图:


二、实验配置要求:

(一)、switch0所连局域网的配置要求
1)根据图示要求划分为vlan1vlan2vlan3
2)服务器使用静态nat,转换后的地址属于222.222.222.0/24网段
3pc机使用动态natnat地址池的地址属于222.222.222.0/24网段
4)通过配置保证switch0stp选举过程中一定能成为根网桥
5Server0向外提供web服务,且其域名为www.aaa.com
6vlan2中的主机pc0pc2分配静态ip地址
7vlan3中的主机pc1pc3通过Server1提供的dhcp服务动态获得192.168.1.120                                            192.168.1.130之间的ip地址

(二)、switch3所连局域网的配置要求
1)根据图示要求划分为vlan1vlan2
2)服务器使用静态nat,转换后的地址属于172.16.2.0/24网段
3pc机使用端口nat,转换到地址172.16.6.2/24
4Server2向外提供web服务,且其域名为www.bbb.com
5Server3vlan2中的主机提供dhcp服务,分配192.168.1.100192.168.1.105ip地址

(三)、switch1所连局域网的配置要求
1)不需要使用nat
2)服务器为图中所有其他Web服务器(即Server0Server1Server3)提供DNS服务

(四)、switch5所连局域网的配置要求
1)根据图示要求划分为vlan1vlan2
2Server5向外提供web服务,且其域名为www.ccc.com
3)服务器使用静态nat,转换后的地址属于172.16.7.0/24网段
4pc机使用静态ip地址
5pc机使用端口nat,转换到ip地址111.111.111.0/24
6)在Goya上配置默认路由

(五)、中间由多台路由器组成的互联网络
1)在GlennCooper上配置rip动态路由协议
2)在Cooper上配置到达目标网络111.111.111.0/24的静态路由
3)不能在Goya上配置rip动态路由协议

(六)、配置成功的要求:
1)所有机器能够互相ping
2)所有机器能够利用域名访问所有的web服务器

三、实验步骤:

(一)ROUTE的配置

步骤1:路由器ip的配置

如图连接好中间广域网的五个路由器,并启用rip协议,宣告172.16.0.0网络(rip协议只识别分类网络),并在相应接口上设置好时钟。

 

步骤2:Cooper的配置
Router(config)# int f0/1.1
Router(config-subif)# encapsolution dot1q 10                  //配置单臂路由
Router(config-subif)# ip address 192.168.1.65 255.255.255.240

Router(config-subif)#ip helper-address 192.168.1.71          //设置DHCP中继代理
Router(config)# int f0/1.2
Router(config-subif)# encapsolution dot1q 20                  //配置单臂路由
Router(config-subif)# ip address 192.168.2.97 255.255.255.240
Router(config)# int f0/1
Router(config-if)# ip nat inside
Router(config-if)# int s0/0
Router(config-if)# ip nat outside
Router(config)-if# int s0/3
Router(config-if)# ip nat outside
Router(config)# ip nat inside source static 192.168.1.71 172.16.2.71 //静态nat
Router(config)# ip nat inside source static 192.168.1.70 172.16.2.70 //静态nat
Router(config)# access-list 1 permit 192.168.1.96 0.0.0.15
Router(config)# ip nat inside source list 1 int s1/1 overload        //端口PAT
查看nat转换表:Router# show ip nattranslations

 

步骤3:Carprenter的配置

Router(config)#int f0/0

Router(config-if)#ip address200.0.0.1 255.255.255.0

Router(config-if)#no shutdown

Router(config)#router rip

Router(config-router)#network200.0.0.0

 

步骤4Goya的配置
Router(config)# int f0/1.1
Router(config-subif)# encapsolution dot1q 10  //配置单臂路由
Router(config-subif)# ip address 192.168.1.65 255.255.255.240
Router(config)# int f0/1.2
Router(config-subif)# encapsolution dot1q 20  //配置单臂路由
Router(config-subif)# ip address 192.168.2.113 255.255.255.240
Router(config)# int f0/1
Router(config-if)# ip nat inside
Router(config-if)# int f0/0
Router(config-if)# ip nat outside
Router(config)# ip nat inside source static 192.168.1.120 172.16.7.120  //
静态nat
Router(config)#ip nat pool NAT1 111.111.111.111 111.111.111.111

netmask 255.255.255.0                 //转换ip地址到111.111.111.0/24网段
Router(config)# access-list 1 permit 192.168.1.64 0.0.0.15
Router(config)# ip nat inside source list 1 pool NAT1 overload         //
端口nat
查看nat转换表:
Router# show ip nat translations
注意为末梢路由器,不参与rip路由,为了使内网的机器访问外网,在Goya上配置默认路由:
Router(config)# ip route 0.0.0.0 0.0.0.0 f0/1
Router(config)# ip route 111.111.111.0 255.255.255.0 172.16.7.2
Router(config)# router rip         //Goya不参与rip路由,通过rip协议重分布该静态路由
Router(config-router)# redistribute static

 

步骤5Glenn的配置

在Glenn中连接switch0的接口上配置单臂路由:
Router(config)# int f0/0.1
Router(config-subif)# encapsolution dot1q 10   //配置单臂路由
Router(config-subif)# ip address 192.168.1.65 255.255.255.240
Router(config)# int f0/0.2
Router(config-subif)# encapsolution dot1q 20   //配置单臂路由
Router(config-subif)# ip address 192.168.2.97 255.255.255.240
Router(config)# int f0/0.3
Router(config-subif)# encapsolution dot1q 30   //配置单臂路由
Router(config-subif)# ip address 192.168.2.113 255.255.255.240
Router(config)# int f0/0.3                     //设置DHCP中继代理
Router(config-subif)# ip helper-address 192.168.1.71
Router(config)# int f0/0
Router(config-if)# ip nat inside
Router(config)# int s0/2
Router(config-if)# ip nat outside
Router(config)# int s0/3
Router(config-if)# ip nat outside
Router(config)# ip nat inside source static 192.168.1.70 222.222.222.70
Router(config)# ip nat inside source static 192.168.1.71 222.222.222.71  //配置服务器的静态NAT
Router(config)#ip nat pool NAT1 222.222.222.100 222.222.222.109 netmask255.255.255.0
Router(config)#ip nat pool NAT2 222.222.222.120 222.222.222.129 netmask255.255.255.0
Router(config)# access-list 2 permit 192.168.1.96 0.0.0.15
Router(config)# access-list 3 permit 192.168.1.112 0.0.0.15
Router(config)# ip nat inside source list 2 pool NAT1overload
Router(config)# ip nat inside source list 3 pool NAt2overload
Router(config)# interface Loopback0
Router(config-if)# ip address 222.222.222.1 255.255.255.0  //配置环回端口
Router(config)# router rip
Router(config-router)# network 222.222.222.0             //通告网络

(二)SWITCH的配置

 

步骤1:switch0的配置
Switch(config)#vlan 10
Switch(config-vlan)#name vlan_for_server
Switch(config)#vlan 20
Switch(config-vlan)#name vlan_for_pc1
Switch(config)#vlan 30
Switch(config-vlan)#name vlan_for_pc2
Switch(config)#int f0/4
Switch(config-if)#switchport access vlan 10
Switch(config-if)#int f0/5
Switch(config-if)#switchport access vlan 10
Switch(config-if)#int f0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#int f0/2
Switch(config-if)#switchport mode trunk
Switch(config-if)#int f0/3
Switch(config-if)#switchport mode trunk
Switch(config)#spanning-tree vlan 1,10,20,30 root primary   //将switch0指定为根网桥

 

步骤2:switch4的配置

Switch(config)#vlan 10
Switch(config-vlan)#name vlan_for_server
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name vlan_for_pc1
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#name vlan_for_pc2
Switch(config-vlan)#exit
Switch(config)#int f0/3
Switch(config-if)#switchport access vlan 20
Switch(config)#int f0/4
Switch(config-if)#switchport access vlan 30
Switch(config)#int f0/2
Switch(config-if)#switchport mode trunk
Switch(config)#spanning-tree vlan 1,10,20,30

 

步骤3:switch5的配置

Switch(config)#vlan 10
Switch(config-vlan)#name vlan_for_server
Switch(config)#vlan 20
Switch(config-vlan)#name vlan_for_pc1
Switch(config)#vlan 30
Switch(config-vlan)#name vlan_for_pc2
Switch(config)#int f0/3
Switch(config)#switchport access vlan 20
Switch(config-if)#int f0/4
Switch(config-if)#switchport access vlan 30
Switch(config)#int f0/1
Switch(config-if)#switchport mode trunk
Switch(config)#spanning-tree vlan 1,10,20,30

 

步骤4:switch2的配置
Switch(config)#vlan 10
Switch(config-vlan)#name vlan_for_pc
Switch(config)#vlan 20
Switch(config-vlan)#name vlan_for_server
Switch(config)#int f0/2
Switch(config-if)#switchport access vlan 10
Switch(config-if)#int f0/3
Switch(config-if)#switchport access vlan 20
Switch(config-if)#int f0/1
Switch(config-if)#switchport mode trunk
查看vlan配置:Switch#show vlan brief

 

步骤5:switch3的配置
Switch(config)#vlan 10
Switch(config-vlan)#name vlan_for_server
Switch(config)#vlan 20
Switch(config-vlan)#name vlan_for_pc
Switch(config)#int f0/4
Switch(config-if)#switchport access vlan 10
Switch(config)#int f0/5
Switch(config-if)#switchport access vlan 10
Switch(config)#int f0/2
Switch(config-if)#switchport access vlan 20
Switch(config)#int f0/3
Switch(config-if)#switchport access vlan 20
Switch(config)#int f0/1
Switch(config-if)#switchport mode trunk
查看vlan配置:Switch#show vlan brief

 

(三)服务器和pc的配置

 

步骤1:配置WEB

WEB(aaa):

WEB(bbb):

 

WEB(ccc):

步骤2:配置DNS

 

步骤3:配置DHCP

DHCP——server4

 

DHCP——server2

四、实验结果:

(一)Ping服务器和pc机

 

 

(二)pingWEB:

 

(三)show ip route

一、实验拓扑图:

二、实验配置要求:

(一)、switch0所连局域网的配置要求
1)根据图示要求划分为vlan1vlan2vlan3
2)服务器使用静态nat,转换后的地址属于222.222.222.0/24网段
3pc机使用动态natnat地址池的地址属于222.222.222.0/24网段
4)通过配置保证switch0stp选举过程中一定能成为根网桥
5Server0向外提供web服务,且其域名为www.aaa.com
6vlan2中的主机pc0pc2分配静态ip地址
7vlan3中的主机pc1pc3通过Server1提供的dhcp服务动态获得192.168.1.120                                            192.168.1.130之间的ip地址

(二)、switch3所连局域网的配置要求
1)根据图示要求划分为vlan1vlan2
2)服务器使用静态nat,转换后的地址属于172.16.2.0/24网段
3pc机使用端口nat,转换到地址172.16.6.2/24
4Server2向外提供web服务,且其域名为www.bbb.com
5Server3vlan2中的主机提供dhcp服务,分配192.168.1.100192.168.1.105ip地址

(三)、switch1所连局域网的配置要求
1)不需要使用nat
2)服务器为图中所有其他Web服务器(即Server0Server1Server3)提供DNS服务

(四)、switch5所连局域网的配置要求
1)根据图示要求划分为vlan1vlan2
2Server5向外提供web服务,且其域名为www.ccc.com
3)服务器使用静态nat,转换后的地址属于172.16.7.0/24网段
4pc机使用静态ip地址
5pc机使用端口nat,转换到ip地址111.111.111.0/24
6)在Goya上配置默认路由

(五)、中间由多台路由器组成的互联网络
1)在GlennCooper上配置rip动态路由协议
2)在Cooper上配置到达目标网络111.111.111.0/24的静态路由
3)不能在Goya上配置rip动态路由协议

(六)、配置成功的要求:
1)所有机器能够互相ping
2)所有机器能够利用域名访问所有的web服务器

三、实验步骤:

(一)ROUTE的配置

步骤1:路由器ip的配置

如图连接好中间广域网的五个路由器,并启用rip协议,宣告172.16.0.0网络(rip协议只识别分类网络),并在相应接口上设置好时钟。

 

步骤2:Cooper的配置
Router(config)# int f0/1.1
Router(config-subif)# encapsolution dot1q 10                  //配置单臂路由
Router(config-subif)# ip address 192.168.1.65 255.255.255.240

Router(config-subif)#ip helper-address 192.168.1.71          //设置DHCP中继代理
Router(config)# int f0/1.2
Router(config-subif)# encapsolution dot1q 20                  //配置单臂路由
Router(config-subif)# ip address 192.168.2.97 255.255.255.240
Router(config)# int f0/1
Router(config-if)# ip nat inside
Router(config-if)# int s0/0
Router(config-if)# ip nat outside
Router(config)-if# int s0/3
Router(config-if)# ip nat outside
Router(config)# ip nat inside source static 192.168.1.71 172.16.2.71 //静态nat
Router(config)# ip nat inside source static 192.168.1.70 172.16.2.70 //静态nat
Router(config)# access-list 1 permit 192.168.1.96 0.0.0.15
Router(config)# ip nat inside source list 1 int s1/1 overload        //端口PAT
查看nat转换表:Router# show ip nattranslations

 

步骤3:Carprenter的配置

Router(config)#int f0/0

Router(config-if)#ip address200.0.0.1 255.255.255.0

Router(config-if)#no shutdown

Router(config)#router rip

Router(config-router)#network200.0.0.0

 

步骤4Goya的配置
Router(config)# int f0/1.1
Router(config-subif)# encapsolution dot1q 10  //配置单臂路由
Router(config-subif)# ip address 192.168.1.65 255.255.255.240
Router(config)# int f0/1.2
Router(config-subif)# encapsolution dot1q 20  //配置单臂路由
Router(config-subif)# ip address 192.168.2.113 255.255.255.240
Router(config)# int f0/1
Router(config-if)# ip nat inside
Router(config-if)# int f0/0
Router(config-if)# ip nat outside
Router(config)# ip nat inside source static 192.168.1.120 172.16.7.120  //
静态nat
Router(config)#ip nat pool NAT1 111.111.111.111 111.111.111.111

netmask 255.255.255.0                 //转换ip地址到111.111.111.0/24网段
Router(config)# access-list 1 permit 192.168.1.64 0.0.0.15
Router(config)# ip nat inside source list 1 pool NAT1 overload         //
端口nat
查看nat转换表:
Router# show ip nat translations
注意为末梢路由器,不参与rip路由,为了使内网的机器访问外网,在Goya上配置默认路由:
Router(config)# ip route 0.0.0.0 0.0.0.0 f0/1
Router(config)# ip route 111.111.111.0 255.255.255.0 172.16.7.2
Router(config)# router rip         //Goya不参与rip路由,通过rip协议重分布该静态路由
Router(config-router)# redistribute static

 

步骤5Glenn的配置

在Glenn中连接switch0的接口上配置单臂路由:
Router(config)# int f0/0.1
Router(config-subif)# encapsolution dot1q 10   //配置单臂路由
Router(config-subif)# ip address 192.168.1.65 255.255.255.240
Router(config)# int f0/0.2
Router(config-subif)# encapsolution dot1q 20   //配置单臂路由
Router(config-subif)# ip address 192.168.2.97 255.255.255.240
Router(config)# int f0/0.3
Router(config-subif)# encapsolution dot1q 30   //配置单臂路由
Router(config-subif)# ip address 192.168.2.113 255.255.255.240
Router(config)# int f0/0.3                     //设置DHCP中继代理
Router(config-subif)# ip helper-address 192.168.1.71
Router(config)# int f0/0
Router(config-if)# ip nat inside
Router(config)# int s0/2
Router(config-if)# ip nat outside
Router(config)# int s0/3
Router(config-if)# ip nat outside
Router(config)# ip nat inside source static 192.168.1.70 222.222.222.70
Router(config)# ip nat inside source static 192.168.1.71 222.222.222.71  //配置服务器的静态NAT
Router(config)#ip nat pool NAT1 222.222.222.100 222.222.222.109 netmask255.255.255.0
Router(config)#ip nat pool NAT2 222.222.222.120 222.222.222.129 netmask255.255.255.0
Router(config)# access-list 2 permit 192.168.1.96 0.0.0.15
Router(config)# access-list 3 permit 192.168.1.112 0.0.0.15
Router(config)# ip nat inside source list 2 pool NAT1overload
Router(config)# ip nat inside source list 3 pool NAt2overload
Router(config)# interface Loopback0
Router(config-if)# ip address 222.222.222.1 255.255.255.0  //配置环回端口
Router(config)# router rip
Router(config-router)# network 222.222.222.0             //通告网络

(二)SWITCH的配置

 

步骤1:switch0的配置
Switch(config)#vlan 10
Switch(config-vlan)#name vlan_for_server
Switch(config)#vlan 20
Switch(config-vlan)#name vlan_for_pc1
Switch(config)#vlan 30
Switch(config-vlan)#name vlan_for_pc2
Switch(config)#int f0/4
Switch(config-if)#switchport access vlan 10
Switch(config-if)#int f0/5
Switch(config-if)#switchport access vlan 10
Switch(config-if)#int f0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#int f0/2
Switch(config-if)#switchport mode trunk
Switch(config-if)#int f0/3
Switch(config-if)#switchport mode trunk
Switch(config)#spanning-tree vlan 1,10,20,30 root primary   //将switch0指定为根网桥

 

步骤2:switch4的配置

Switch(config)#vlan 10
Switch(config-vlan)#name vlan_for_server
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#name vlan_for_pc1
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config-vlan)#name vlan_for_pc2
Switch(config-vlan)#exit
Switch(config)#int f0/3
Switch(config-if)#switchport access vlan 20
Switch(config)#int f0/4
Switch(config-if)#switchport access vlan 30
Switch(config)#int f0/2
Switch(config-if)#switchport mode trunk
Switch(config)#spanning-tree vlan 1,10,20,30

 

步骤3:switch5的配置

Switch(config)#vlan 10
Switch(config-vlan)#name vlan_for_server
Switch(config)#vlan 20
Switch(config-vlan)#name vlan_for_pc1
Switch(config)#vlan 30
Switch(config-vlan)#name vlan_for_pc2
Switch(config)#int f0/3
Switch(config)#switchport access vlan 20
Switch(config-if)#int f0/4
Switch(config-if)#switchport access vlan 30
Switch(config)#int f0/1
Switch(config-if)#switchport mode trunk
Switch(config)#spanning-tree vlan 1,10,20,30

 

步骤4:switch2的配置
Switch(config)#vlan 10
Switch(config-vlan)#name vlan_for_pc
Switch(config)#vlan 20
Switch(config-vlan)#name vlan_for_server
Switch(config)#int f0/2
Switch(config-if)#switchport access vlan 10
Switch(config-if)#int f0/3
Switch(config-if)#switchport access vlan 20
Switch(config-if)#int f0/1
Switch(config-if)#switchport mode trunk
查看vlan配置:Switch#show vlan brief

 

步骤5:switch3的配置
Switch(config)#vlan 10
Switch(config-vlan)#name vlan_for_server
Switch(config)#vlan 20
Switch(config-vlan)#name vlan_for_pc
Switch(config)#int f0/4
Switch(config-if)#switchport access vlan 10
Switch(config)#int f0/5
Switch(config-if)#switchport access vlan 10
Switch(config)#int f0/2
Switch(config-if)#switchport access vlan 20
Switch(config)#int f0/3
Switch(config-if)#switchport access vlan 20
Switch(config)#int f0/1
Switch(config-if)#switchport mode trunk
查看vlan配置:Switch#show vlan brief

 

(三)服务器和pc的配置

 

步骤1:配置WEB

WEB(aaa):

WEB(bbb):

 

WEB(ccc):

步骤2:配置DNS

 

步骤3:配置DHCP

DHCP——server4

 

DHCP——server2

四、实验结果:

(一)Ping服务器和pc机

 

 

(二)pingWEB:

 

(三)show ip route


0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:6848次
    • 积分:178
    • 等级:
    • 排名:千里之外
    • 原创:11篇
    • 转载:1篇
    • 译文:0篇
    • 评论:2条
    最新评论