codeforces 699B One Bomb (思维)

B - One Bomb

Time Limit:1000MS    Memory Limit:262144KB     64bit IO Format:%I64d & %I64u      uDebug    

Description

Input

Output

Sample Input

Sample Output

Hint

Description

You are given a description of a depot. It is a rectangular checkered field ofn × m size. Each cell in a field can be empty (".") or it can be occupied by a wall ("*").

You have one bomb. If you lay the bomb at the cell (x, y), then after triggering it will wipe out all walls in the rowx and all walls in the column y.

You are to determine if it is possible to wipe out all walls in the depot by placing and triggeringexactly one bomb. The bomb can be laid both in an empty cell or in a cell occupied by a wall.

Input

The first line contains two positive integers n andm (1 ≤ n, m ≤ 1000) — the number of rows and columns in the depot field.

The next n lines contain m symbols "." and "*" each — the description of the field.j-th symbol in i-th of them stands for cell(i, j). If the symbol is equal to ".", then the corresponding cell is empty, otherwise it equals "*" and the corresponding cell is occupied by a wall.

Output

If it is impossible to wipe out all walls by placing and triggering exactly one bomb, then print "NO" in the first line (without quotes).

Otherwise print "YES" (without quotes) in the first line and two integers in the second line — the coordinates of the cell at which the bomb should be laid. If there are multiple answers, print any of them.

Sample Input

Input
3 4
.*..
....
.*..
Output
YES
1 2
Input
3 3
..*
.*.
*..
Output
NO
Input
6 5
..*..
..*..
*****
..*..
..*..
..*..
Output
YES
3 3

题目大意:在平面内某一点放置一个炸弹,该炸弹可以令其所在行所在列的墙消失,问是否存在一个点,在该点放置炸弹可以令所有的墙消失

解题思路:因为数据量比较大,不能使用太过暴力的做法,所以要用合适的办法表示某一行的炸弹,和某一列的炸弹,考虑到是以行或列作为计算的主体,所以只需按行(列)计算出其中的炸弹的数量即可。然后只需要遍历一遍,就可以判断是否炸掉所有的墙。

#include <iostream>
#include <cstdio>
using namespace std;
char s[1005][1005];
int h[1005];
int l[1005];
int n,m,num;
int main()
{
    //freopen("test.txt","r",stdin);
    cin>>n>>m;
    int i,j;
    for(i=1;i<=n;i++)
    {
        scanf("%s",s[i]+1);
    }
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=m;j++)
        {
            if(s[i][j]=='*')
            {
                h[i]++;
                l[j]++;
                num++;
            }

        }
    }

    int x,y;

    int flag = 0;
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=m;j++)
        {
            if(s[i][j]=='*')
            {
                if(h[i]+l[j]-1==num)
                {
                    flag = 1;break;
                }
            }
            else
            {
                if(h[i]+l[j]==num)
                {
                    flag = 1;
                    break;
                }
            }
        }
        if(flag)
            break;
    }
    if(!flag)
        cout << "NO" << endl;
    else
    {
        cout << "YES" << endl;
        cout << i << ' ' << j <<endl;
    }
    //cout << "Hello world!" << endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值