关闭

android错误:Plugin is too old 解决方法

52人阅读 评论(0) 收藏 举报
分类:

在使用android studio开发时,经常会遇到Plugin is too old的错误


解决的办法:

打开下图的文件


其中有如下代码:

classpath 'com.android.tools.build:gradle:2.2.0-alpha5'


***:就是这个工具的版本不对,会造成以上问题,这里修改正确后即可正常。(本地目录里面要有适合的版本(一般最新即可))


查看本地有哪些版本,本机路径:

C:\Users\wdd\.gradle\caches\modules-2\files-2.1\com.android.tools.build\builder


网上可下载的版本,修改build.gradle文件后可以自动下载,如果手动下载,需要放到本地的路径里面
http://jcenter.bintray.com/com/android/tools/build/builder/


File->setting



gradle的下载地址:

http://services.gradle.org/distributions/

下载最新版本:(例如:gradle-3.0-all.zip)解压后复制到Android studio/gradle的目录里。

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:324次
    • 积分:52
    • 等级:
    • 排名:千里之外
    • 原创:5篇
    • 转载:0篇
    • 译文:0篇
    • 评论:0条
    文章分类
    文章存档