Robotium 运行时Installation error INSTALL_FAILED_VERSION_DOWNGRADE错误

转载 2015年11月20日 15:21:22

最近折腾了一下Robotium自动化测试框架,发现问题还挺多,刚刚解决了一个问题,总算是把环境搞定了,可是一运行测试用例,发现又报Installationerror INSTALL_FAILED_VERSION_DOWNGRADE错误了。网上查了一下,说是AndroidManifest.xmlversionCode有点儿小了,应该改大一点儿就行了。默认是如下的:

 package="com.test.apppage"

     android:versionCode="1"

   android:versionName="1.0"

于是我就改这个versionCode,一直从1都改到20了,还是不行,于是就要想,能不能查看一下我的App的versionCode呢?

  在网上搜了一下,发现还真可以,具体的办法如下:

1,使用Aapt工具,位置:$PATH\adt-bundle-windows-x86_64-20140702\sdk\build-tools\android-4.4W(这是我的,你可以搜索一下自己的)

aapt工具,平时我们不会用这个东西,但是打包成Apk的时候其实是用到了的,只不过IDE替我们做了这一步,那么我们就用这个工具来查看VersionCodeVersionName

查看apk包的packageNameversionCodeapplicationLabellauncherActivitypermission等各种详细信息

2,执行命令:

C:\aapt dump badgingzhongchou.app

如果没有设置相应该的PATH,去aapt.exe所在的路径下执行即可。

3,查看pageageName,versionCode

Robotium <wbr>运行时Installation <wbr>error <wbr>INSTALL_FAILED_VERSION_DOWNGRADE错误

 

然后将AndroidManifest.xmlversionCode改成这个数值,或是比这个数值大就可以了!!

android错误:Installation error: INSTALL_FAILED_VERSION_DOWNGRADE

这个错误是  android:versionCode的值太小 解决方法是改变这个值  为了快速测试  我一直是立马改成200 绝对没有问题...

Android运行报错Installation error: INSTALL_FAILED_CONTAINER_ERROR

在网上搜索到的解决办吧: 当我部署一个Eclipse中的项目时,提示Installation error: INSTALL_FAILED_CONTAINER_ERROR,通过在网上上查找解决放啊按得...

Installation error: INSTALL_FAILED_CONFLICTING_PROVIDER

Installation error: INSTALL_FAILED_CONFLICTING_PROVIDER

关于Installation error: INSTALL_FAILED_INSUFFICIENT_STORAGE的报错的最有效的解决方法

好久没有在真的Android机子上运行程序了,

android 应用未安装 及 Installation error: INSTALL_FAILED_UPDATE_INCOMPATIBLE

记录一个问题,尚未完全解决,但也算是一个暂时的解决办法,项目时间很紧张,就先这样吧。 以前有碰到过应用调试的程序可以安装运行,但是打包之后的apk可以安装但是无法运行的问题,当时根据自己这个版本针对...
  • zyzhehe
  • zyzhehe
  • 2015年05月13日 06:49
  • 513

shared user id / Installation error: INSTALL_FAILED_SHARED_USER_INCOMPATIBLE .

在windows平台通过eclipse编译android源码中,如果编译Settings或者android manifest XML中 shared user id 包含android.uid.sha...

shared user id / Installation error: INSTALL_FAILED_SHARED_USER_INCOMPATIBLE

-----在windows平台通过eclipse编译android源码中,如果编译Settings或者android manifest XML中 shared user id 包含android.ui...

关于Installation error: INSTALL_FAILED_NO_MATCHING_ABIS的解决方法

遇到过好几次这种错误提示,工程代码没有任何错误,但是连安装都安装不上模拟器,console控制台就报出上面的错误:[2015-11-25 15:15:37 - Em4.x] Installation ...

Installation error: INSTALL_FAILED_SHARED_USER_INCOMPATIBLE

修改Android系统APK(DownloadProvider)完成后, 运行报错:   [2012-05-07 19:45:54 - DownloadProviderUI] Installatio...

Installation error: INSTALL_FAILED_UPDATE_INCOMPATIBLE

Installation error: INSTALL_FAILED_UPDATE_INCOMPATIBLE 晚上在测一个widget,前面测的好好的,后面再安装的时候发现如下错误: [2...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Robotium 运行时Installation error INSTALL_FAILED_VERSION_DOWNGRADE错误
举报原因:
原因补充:

(最多只允许输入30个字)