poj2255有树的先序,中序遍历,找出树的后序遍历

Tree Recovery

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 4
Problem Description
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:
                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!

 

Input
The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.

 

Output
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
 

Sample Input
  
  
DBACEGF ABCDEFG BCAD CBAD
 

Sample Output
  
  
ACBFGED CDAB 根据先序遍历的特点,第一个节点一定是整棵树的根节点,中序遍历中树的根节点把树分为左右两个子树,根据中序遍历将先序遍历 ,中序遍历都分为两个子树,再对这两棵子树进行递归,就可以找到后序遍历的结果了 代码如下: (有先序遍历和中序遍历找后续遍历的,和有中序遍历和后续遍历找先序遍历的操作步骤是一样的,只不过在实现的时候找后续遍历时在递归之后输出节点,找先序遍历的话,在递归之前输出节点)
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 30
char sf[maxn],sm[maxn];
void dfs(int fl,int fr,int ml,int mr)
{
    int i;
    for(i=ml;i<=mr;i++)
    {
        if(sf[fl]==sm[i])
            break;
    }
    int root=i;
    int lsize=root-ml;
    int rsize=mr-root;
    if(lsize>0)
        dfs(fl+1,fl+lsize,ml,root-1);
    if(rsize>0)
        dfs(fl+lsize+1,fr,root+1,mr);
    printf("%c",sm[root]);//递归到最后只剩于单独的一个节点即为root节点,所以将root节点输出即可。
}
int main()
{
    while(scanf("%s %s",sf,sm)!=EOF)
    {
        int n=strlen(sf);
        dfs(0,n-1,0,n-1);
        cout<<endl;
    }
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Ink__Bamboo

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值