树状数组简单题----杭电1541

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5142    Accepted Submission(s): 2021


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
  
  
1 2 1 1

0

本题目的大致意思就是:找出本层向下,或向左的所有星星的个数,因为输入数据已经按照y进行排序,所以不必对输入数据进行排序即可操作,看完大神写的博客后发现使用树状数组实现的,所以一下不在啰嗦树状数组实现,不过在输入的时候需要注意的是由于输入的坐标可能有0的可能,所以在操作的时候将坐标统一的x++向右移动一个单位,但是各点之间的相对位置没有发生变化,不影响最终的结果。

代码如下:

#include <stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
#define maxn 320010
int a[maxn],b[maxn],n;
int lowbit(int x)<span style="white-space:pre">	</span>//找出x末尾0的个数
{
    return x&(-x);
}
void update(int x)<span style="white-space:pre">	</span>//对数组中的数据更新
{

    while(x<=maxn)
    {
        a[x]++;
        x+=lowbit(x);
    }
}
int sum(int x)<span style="white-space:pre">		</span>//求前x个元素的和
{
    int sum = 0;
    while(x>0)
    {
        sum+=a[x];
        x-=lowbit(x);
    }
    return sum;
}
int main()
{
    int x,y;
    while(scanf("%d",&n)!=EOF)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=0;i<n;i++)
        {
              scanf("%d %d",&x,&y);
              b[sum(x+1)]++;<span style="white-space:pre">		</span>//x+1操作避免出现输入数据存在x=0的情况
              update(x+1);
        }
        for(int i=0;i<n;i++)
            printf("%d\n",b[i]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Ink__Bamboo

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值