Find a way+二次广搜

38 篇文章 0 订阅
19 篇文章 0 订阅

Find a way

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2374    Accepted Submission(s): 750


Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
 

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 

Sample Input
  
  
4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5 Y..@. .#... .#... @..M. #...#
 

Sample Output
  
  
66 88 66
 

Author
yifenfei
 

Source
 

Recommend
yifenfei
 
/*思路:两次广搜,从‘Y’,‘M’开始搜索,保存在每个'@'点的距离
最后求到每个@的最小值,
注意:别从每个@搜索到M,Y,那样会超时
*/

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
typedef struct infor
{
	int x,y,step;
}infor;
queue<infor>q;
char s[202][202];
int Step[202][202],move[4][2]={{0,-1},{0,1},{1,0},{-1,0}};
int n,m,min1,min2,min3;
infor save[1002];
int k;
int a1[1002],b1[1002];
bool inmap(int x,int y){
	if(x>=0&&x<n&&y>=0&&y<m&&s[x][y]!='#')
		return true;
	else
		return false;
}

void BFS(int x,int y,char ch){
	infor a;
	a.x=x;
	a.y=y;
	a.step=0;
	q.push(a);

	while(!q.empty()){
		infor b=q.front();
		q.pop();
		for(int i=0;i<4;i++){
			infor c=b;
			c.x+=move[i][0];
			c.y+=move[i][1];
			c.step++;
			if(inmap(c.x,c.y)&&Step[c.x][c.y]>c.step){
				Step[c.x][c.y]=c.step;
				for(int j=0;j<k;j++)
					if(save[j].x==c.x&&save[j].y==c.y){
					if(ch=='Y')
						a1[j]=c.step;
					else
						b1[j]=c.step;
					}
				q.push(c);
			}
		}
	}
}

int main()
{
	while(cin>>n>>m){
		int i,j;
		int yx,yy;
		int mx,my;
		k=0;
		min2=10000000;
		for(i=0;i<n;i++)
			for(j=0;j<m;j++){
				cin>>s[i][j];
				if(s[i][j]=='Y'){
					yx=i;
					yy=j;
				}
				if(s[i][j]=='M'){
					mx=i;
					my=j;
				}
				if(s[i][j]=='@'){
					save[k].x=i;
					save[k++].y=j;
				}

			}
		memset(a1,'1000',sizeof(a1));
		memset(b1,'1000',sizeof(b1));
		memset(Step,'1000',sizeof(Step));
		BFS(yx,yy,'Y');
		memset(Step,'1000',sizeof(Step));
		BFS(mx,my,'M');
		for(i=0;i<k;i++)
			min2=min2>(a1[i]+b1[i])?(a1[i]+b1[i]):min2;
		cout<<min2*11<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值