The Special Number

The Special Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1377    Accepted Submission(s): 380


Problem Description
In this problem, we assume the positive integer with the following properties are called ‘the special number’:
1) The special number is a non-negative integer without any leading zero.
2) The numbers in every digit of the special number is unique ,in decimal system.
Of course,it is easy to check whether one integer is a ‘special number’ or not, for instances, 1532 is the ‘special number’ and 101 is not. However, we just want to know the quantity of the special numbers that is less than N in this problem.
 

Input
The input will consist of a series of signed integers which are not bigger than 10,000,000. one integer per line. (You may assume that there are no more than 20000 test cases)
 

Output
For each case, output the quantity of the special numbers that is less than N in a single line.
 

Sample Input
  
  
10 12
 

Sample Output
  
  
9 10
 
/*
题意:
给你一个数n,要求你求出小于n的special number的个数。special number的定义:
1.没有前导0;
2.每位上的数字不一样,即101不是,111也不是

思路:
类似打表先求出1-10000000之间满足special number的数据存在a[]中
再用二分查询查找输入的n位于a[]的下标是多少,即答案。
*/
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define MAX 10000005
int a[MAX] , j = 0 ;
void fun()
{
	int i ,b[10];
	for( i = 1; i <=10000000 ; i++) //枚举1到MAX之间的所有数据,判断是否满足special number的要求,满足则保存到a[]
	{
		int m = i ,flag = 0 ;
		memset(b,0,sizeof(b));
		while(m) //判断是否有位数相同
		{
			b[m%10] ++ ;
			if(b[m%10]>=2)
			{
				flag =1 ;
				break;
			}
			m /= 10 ;
		}
		if(!flag)
			a[j++] = i ;
	}
}

/*二分查找*/
int Binary_Search(int x)
{
	int low = 0 , high = j-1 ,mid ;
	while(low <= high)
	{
		mid = (low + high) / 2 ;
		if(a[mid] < x)
			low = mid + 1;
		else
			high = mid - 1 ;
	}
	return low ;
}
int main(void)
{
	fun();
	int m ;
	while(scanf("%d",&m) != EOF)
	{
		printf("%d\n",Binary_Search(m));
	}
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值