poj 1740 A New Stone Game

12 篇文章 0 订阅
A New Stone Game
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4372 Accepted: 2356

Description

Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn.
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones.
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states.
2 1 4 2
1 2 4 2(move one stone to Pile 2)
1 1 5 2(move one stone to Pile 3)
1 1 4 3(move one stone to Pile 4)
0 2 5 2(move one stone to Pile 2 and another one to Pile 3)
0 2 4 3(move one stone to Pile 2 and another one to Pile 4)
0 1 5 3(move one stone to Pile 3 and another one to Pile 4)
0 3 4 2(move two stones to Pile 2)
0 1 6 2(move two stones to Pile 3)
0 1 4 4(move two stones to Pile 4)
Alice always moves first. Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.

Input

The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of stones in each pile will not exceed 100.
The last test case is followed by one zero.

Output

For each test case, if Alice win the game,output 1,otherwise output 0.

Sample Input

3
2 1 3
2
1 1
0

Sample Output

1
0
 
题意:两个人玩游戏,有n堆石子,给出初始时每堆石子的数量。每个步首先选择一堆石子,从中移走至少一个石子,然后在这堆石子中选择若干个石子(可以是0个)放到另一堆石子中。总是以ALice开始,最后谁不能操作了谁就输。
思路:(1)当石子成对相等时,例如有6堆石子,各位1,1,2,2,3,3。那么先手必败。因为后手只要做出同先手对称的操作,那么就可以保证不输。
      (2)当石子不成对相等时,后手必败。因为任何不是成对相等的情况都可以由先手转化为成对相等的情况。
 
AC代码:
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <iostream>

using namespace std;

int main()
{
   int plie[105];
   int n,a;
   while(cin>>n,n)
   {
       memset(plie,0,sizeof(plie));
       while(n--)
       {
          cin>>a;
          plie[a]^=1;
       }
       bool flag=true;
       for(int i=0;i<105;i++)
       {
           if(plie[i])
           {
               flag=false;
               break;
           }
       }
       if(flag)
       cout<<0<<endl;
       else
       cout<<1<<endl;
   }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值