20140426 【DP - 状态压缩】 POJ 1753 Flip Game

5 篇文章 0 订阅

Online JudgeProblem SetAuthorsOnline ContestsUser
Web Board
Home Page
F.A.Qs
Statistical Charts
Problems
Submit Problem
Online Status
Prob.ID:
Register
Update your info
Authors ranklist
Current Contest
Past Contests
Scheduled Contests
Award Contest
wilson1068      Log Out
Mail:0(0)
Login Log      Archive
Language:
Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28806 Accepted: 12462

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact Administrator

——————————————————————————————————————————

咳咳,好久没写过了。



说是状态压缩DP,这题实际上只是需要状态压缩+BFS


状态压缩用于记录棋盘状态,

接下来BFS寻找最快的步骤。



display 函数只是用来查看状态的。

——————————————————————————————————————————

#include <iostream>
#include <string>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define m(a)	((a)%(MAXN))
using namespace std;
const int MAXN = 1<<17;
int f[MAXN], q[MAXN];
int ans(int now){
    return ( 0==now || (1<<16)-1==now )?1:0;
}
void set(int &now, int i, int j){
    now = now^(1<<(4*i+j));
}
void display(int now);
int bfs(int now){          // display(now);
    if( ans(now) )    return 0;
    int head=0, tail=0;
    q[++tail] = now;
    f[now] = 1;
    while( head != tail ){
        head = m(head+1);
        int now = q[head];
        for(int i=0; i<4; i++){
            for(int j=0; j<4; j++){
                int a=now;  set(a, i, j);
                if( j>0 )   set(a, i, j-1);
                if( j<3 )   set(a, i, j+1);
                if( i>0 )   set(a, i-1, j);
                if( i<3 )   set(a, i+1, j);
                if( ans(a) )    return f[now];
                else if( !f[a] ){
                    f[a] = f[now]+1;
                    tail = m(tail+1);
                    q[tail] = a;
                }           //    display(a);
            }
        }
    }
	return -999;
}
int main()
{                        //     freopen("1753.in", "r", stdin);
	string s[4];
	while( cin>>s[0]>>s[1]>>s[2]>>s[3] )
	{
		int now = 0;
		for(int i=0; i<4; i++)
			for(int j=0; j<4; j++)
                now = (now<<1) + (('w'==s[i][j])?1:0);
		memset(f, 0, sizeof(f));
		int answer = bfs(now);
		if( answer<0 )  cout<<"Impossible"<<endl;
        else            cout<<answer<<endl;
	}
	return 0;
}













  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值