poj2506--Tiling

Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7288 Accepted: 3546

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source

The UofA Local 2000.10.14
递推的题目主要还是找到规律,这个题的规律比较明显,p[n]的情况可以由p[n-1]加一个竖的,或是由p[n-2]加两个横的,或是p[n-2]加上一个大块得到   由此推出,p[n] = p[n-1] + p[n-2] * 2 ; 
还有的就是一个大数问题,很好解决的大数的加法
#include <stdio.h>
struct node{
    int a[1000] ;
    int top ;
}p[300];
int main()
{
    int n , i ;
    p[0].a[0] = 1 ;
    p[0].top = 1 ;
    p[1].a[0] = 1 ;
    p[1].top = 1 ;
    for(i = 2 ; i <= 250 ; i++)
    {
        int j , s = 0 , k = 0 ;
        for(j = 0 ; j < p[i-1].top ; j++)
        {
            s = p[i-1].a[j] + p[i-2].a[j] * 2 + k ;
            p[i].a[j] = s % 10 ;
            k = s / 10 ;
        }
        p[i].top = p[i-1].top ;
        if(k != 0)
        {
            p[i].a[j] = k ;
            p[i].top++ ;
        }
    }
    while(scanf("%d", &n) !=EOF)
    {
        for(i = p[n].top-1 ; i >= 0 ; i--)
        {
            printf("%d", p[n].a[i]);
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值