poj2993--Emag eht htiw Em Pleh

Emag eht htiw Em Pleh
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2573 Accepted: 1728

Description

This problem is a reverse case of the problem 2996. You are given the output of the problem H and your task is to find the corresponding input.

Input

according to output of problem 2996.

Output

according to input of problem 2996.

Sample Input

White: Ke1,Qd1,Ra1,Rh1,Bc1,Bf1,Nb1,a2,c2,d2,f2,g2,h2,a3,e4
Black: Ke8,Qd8,Ra8,Rh8,Bc8,Ng8,Nc6,a7,b7,c7,d7,e7,f7,h7,h6

Sample Output

+---+---+---+---+---+---+---+---+
|.r.|:::|.b.|:q:|.k.|:::|.n.|:r:|
+---+---+---+---+---+---+---+---+
|:p:|.p.|:p:|.p.|:p:|.p.|:::|.p.|
+---+---+---+---+---+---+---+---+
|...|:::|.n.|:::|...|:::|...|:p:|
+---+---+---+---+---+---+---+---+
|:::|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|...|:::|...|:::|.P.|:::|...|:::|
+---+---+---+---+---+---+---+---+
|:P:|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|.P.|:::|.P.|:P:|...|:P:|.P.|:P:|
+---+---+---+---+---+---+---+---+
|:R:|.N.|:B:|.Q.|:K:|.B.|:::|.R.|
+---+---+---+---+---+---+---+---+

Source

CTU Open 2005
模拟题,重要的是判断好行数和列数,与2996相反的一个题
#include <stdio.h>
#include <string.h>
int main()
{
    int i , j , x , y , l ;
    char s1[] = "+---+---+---+---+---+---+---+---+" ;
    char s2[] = "|:::|...|:::|...|:::|...|:::|...|" ;
    char s3[] = "|...|:::|...|:::|...|:::|...|:::|" ;
    char str[20][40] , s[100] ;
    for(i = 0 ; i < 17 ; i++)
    {
        if(i % 2 == 0)
            strcpy(str[i],s1);
        else if(i % 4 == 1)
            strcpy(str[i],s2);
        else
            strcpy(str[i],s3);
    }
    gets(s);
    l = strlen(s);
    for(i = 7 ; i < l ; )
    {
        if(s[i] >= 'A' && s[i] <= 'Z')
        {
            x = ( s[i+2] - '0' ) * 2 - 1 ;
            y = (s[i+1] - 'a' + 1 ) * 4 - 2 ;
            str[x][y] = s[i] ;
            i += 3 ;
        }
        else if(s[i] >= 'a' && s[i] <= 'z')
        {
            x = ( s[i+1] - '0' )*2 - 1 ;
            y = (s[i] - 'a' + 1 ) * 4 - 2 ;
            str[x][y] = 'P' ;
            i+= 2 ;
        }
        else
            i++ ;
    }
    gets(s);
    l = strlen(s);
    for(i = 7 ; i < l ; )
    {
        if(s[i] >= 'A' && s[i] <= 'Z')
        {
            x = ( s[i+2] - '0' )*2 - 1 ;
            y = (s[i+1] - 'a' + 1 ) * 4 - 2 ;
            str[x][y] = s[i] + 32 ;
            i+= 3 ;
        }
        else if(s[i] >= 'a' && s[i] <= 'z')
        {
            x = ( s[i+1] - '0' )*2 - 1 ;
            y = (s[i] - 'a' + 1 ) * 4 - 2 ;
            str[x][y] = 'p' ;
            i+= 2;
        }
        else
            i++ ;
    }
    for(i = 16 ; i >= 0 ; i--)
        printf("%s\n", str[i]);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值