HDU 1698 Just a Hook (线段树:区间修改+区间查询)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 27354 Accepted Submission(s): 13588

Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

这里写图片描述

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1
10
2
1 5 2
5 9 3

Sample Output

Case 1: The total value of the hook is 24.

解题思路:线段树的基本运用

AC代码如下:

    #include <bits/stdc++.h>
    #define N 100100
    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1
    #define intm int m = (l+r)>>1

    using namespace std;

    struct T{
        int v;//value
        int lz;//lazy 懒操作
    }t[N*4];

    void pushDown(int rt){
        t[rt<<1].v = t[rt<<1|1].v = t[rt].v;
    }

    void update(int L,int R,int v,int l,int r,int rt){
        if(L<=l && r <= R){
            t[rt].v = v;
            t[rt].lz = -1;// 更新这个点为 可以使用
            return;
        }
        if(t[rt].lz == -1){//如果这个值是-1代表着这里的值可以使用,且应该向下传递,为接下来它的左右孩子的更新初始化
            t[rt].lz = 0;
            //代表着此位置的v(value)已不可使用(因为它的v已经不能代表这个区间的值了,所以相应的,在查询时如果这个标志为0则进入它的孩子节点去查询。
            t[rt<<1].lz = t[rt<<1|1].lz = -1;
            pushDown(rt);
        }
        intm;
        if(L <= m)update(L,R,v,lson);
        if(R > m)update(L,R,v,rson);
    }

    int ans;
    void query(int L,int R,int l,int r,int rt){//L,R代表要查询的区间。l,r代表当前走到的区间
        if(L<=l && r <= R && t[rt].lz == -1){
            ans += t[rt].v * (r-l+1);
            return;
        }

        intm;
        if(L <= m)
            query(L,R,lson);
        if(R > m)
            query(L,R,rson);
    }


    int main()
    {
        int ncase;
        cin>>ncase;
        for(int cas = 1;cas <= ncase;cas++){
            memset(t,-1,sizeof(t));// 默认初始化为-1
            t[1].v = 1;// 为保证所有线段的value初始为1

            int n,q;
            scanf("%d%d",&n,&q);

            for(int i = 0;i <q;i++){
                int x,y,z;
                scanf("%d%d%d",&x,&y,&z);
                update(x,y,z,1,n,1);
            }
            query(1,n,1,n,1);
            cout<<"Case "<<cas<<": The total value of the hook is "<<ans<<"."<<endl;
            ans = 0;
        }
        return 0;
    }   
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值