HDU2709Sumsets整数分解为加数,递推公式

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=2709

Sumsets

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2830    Accepted Submission(s): 1134


Problem Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
 

Input
A single line with a single integer, N.
 

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
 

Sample Input
  
  
7
 

Sample Output
  
  
6

题解:这个题当数据量不大的时候,完全可以用搜索得出结果,但数据量大时,会超时。所以,可以先用dfs搜索得出前面若干项的结果,看一下有什么规律。

这个题从1开始,结果一次为 1   2   2   4   4   6   6   10   10   14   14   20   20   26   26   36   36   46   46   60   60   74。

递推公式:p[ i ]=(p[ i-1 ]+p[ i/2 ]) % mod ; (mod=1e9)

AC代码:

#include<stdio.h>
typedef long long ll;
ll mod=1000000000;
ll p[1020000];
void init()
{
    p[1]=1;p[2]=2;
    for(int i=2;i<1000010;i+=2)
    {
        p[i]=(p[i-1]+p[i/2])%mod;
        p[i+1]=p[i];
    }
}
int main()
{
    int n;
    init();
    while(~scanf("%d",&n))
    {
        printf("%lld\n",p[n]);
    }
    return 0;
}

dfs搜索过程:(非AC代码)

#include<stdio.h> 
int pow2[100]={1,2,4,8,16,32,64,128,256,512,1024,2048,4096};
int ans;
void dfs(int n,int last)
{
    if(n==0)
    {
        ans++;
        return;
    }
    for(int i=0;n-pow2[i]>=0;i++)
    {
        if(pow2[i]>=last)
            dfs(n-pow2[i],pow2[i]);
    }
}
int main()
{
    int n;
    //while(~scanf("%d",&n))
    for(n=1;n<40;n++)
    {
        ans=0;
        dfs(n,0);
        printf("   %d",ans);
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

雪的期许

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值