HDU 6090 Rikka with Graph (图论规律题)

Rikka with Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1009    Accepted Submission(s): 583


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

For an undirected graph G with n nodes and m edges, we can define the distance between (i,j) ( dist(i,j) ) as the length of the shortest path between i and j . The length of a path is equal to the number of the edges on it. Specially, if there are no path between i and j , we make dist(i,j) equal to n .

Then, we can define the weight of the graph G ( wG ) as ni=1nj=1dist(i,j) .

Now, Yuta has n nodes, and he wants to choose no more than m pairs of nodes (i,j)(ij) and then link edges between each pair. In this way, he can get an undirected graph G with n nodes and no more than m edges.

Yuta wants to know the minimal value of wG .

It is too difficult for Rikka. Can you help her?  

In the sample, Yuta can choose (1,2),(1,4),(2,4),(2,3),(3,4) .
 

Input
The first line contains a number t(1t10) , the number of the testcases.

For each testcase, the first line contains two numbers n,m(1n106,1m1012) .
 

Output
For each testcase, print a single line with a single number -- the answer.
 

Sample Input
  
  
1 4 5
 

Sample Output
  
  
14
 

Source
【分析】:

听说这叫菊花图。。。

题意:存在一个无向图,n个点,你可以任意的加上m条边,权值为1。然后其余的不存在的边权值为n。

问所有的i点到j点的最短路之和。


推规律,设完全图的边数目为 all = n*(n-1)/2 ,分三种情况:

1、m>all ,直接输出all*2(完全图)

2、m<n-1,无法构成一棵树,这种有点点麻烦。

任意选一点,开始绕着方边,能放多少就放多少。

然后,

长度为1的路有m条

长度为2的路有m个点形成完全图个

剩下的边都是长度为n的

累加起来即可。

3、其他,这种情况下,怎么安排边?

就绕着一个点方边,这个点放完了,换个点接着绕。

这样建图就会形成这样的局势:

有m个权值为1的边,剩下的任意i->j的最短路为2。

【代码】:

#include <stdio.h>
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long ll;
ll T,m,n;
int main()
{
    cin>>T;
    while(T--)
    {
        cin>>n>>m;
        ll all=n*(n-1)/2;
        if(m>=all)
            printf("%lld\n",all*2);
        else if(m<n-1)//有孤点
            printf("%lld\n",2*m+2*m*(m-1)+2*n*( (m+1)*(n-m-1)+(n-m-1)*(n-m-2)/2) );
        else //联通的无向图(包括树)
            printf("%lld\n",2*m+4*(all-m));
    }
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

雪的期许

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值