使用pods的时候再次遇到了一些困难

原创 2016年06月02日 10:23:42
本来没有了root权限之后不能保存关闭podfile,使用了:wq!之后诶。。。。。好了QAQ~~欢喜 了一下子,结果呢?我马上进行pod install命令的时候又来一难题整的我不要不要的,心想特么坑人啊这是才解决了一个又来一个,能不能少一点套路多一点真诚了。

[!] The dependency `MBProgressHUD (~> 0.8)` is not used in any concrete target.

The dependency `AFNetworking (~> 2.1.0)` is not used in any concrete target.

The dependency `JSONKit-NoWarning (~> 1.1)` is not used in any concrete target.

看到没?一看到这种就心碎了说的是没用在target这个下面。。。。。这让我想当然的就往哪个podfile里面去想了我在platform后面强行加了个target还是没什么用处~~~这就是强行逼着我去看官方文档了再次去看了看写成了这样的

target 'TaskView(这个就是你app的哪个名字了别弄错了!)' do pod 'AFNetworking', '~> 2.1.0'  

pod 'JSONKit-NoWaming', '~> 1.1' 

pod 'MBProgressHUD', '~> 0.8'end


也就是说你发现了这个错误之后呢使用命令:open -e Podfile这个文件进行编辑编辑成我上面这种模样的然后commond+s保存关闭编辑再次使用pod install命令就可以了



我想说的是服了!!!!兄弟们有更好的方法给我推荐推荐哈谢谢

相关文章推荐

cocoa pods的安装与我遇到的问题

1.打开终端 终端输入  ruby -v  查看ruby的版本 打印代码: ruby 2.0.0p648 (2015-12-16 revision 53162) [universal...

CocoaPods报错:The dependency `AFNetworking ` is not used in any concrete target

CocoaPods报错:The dependency `` is not used in any concrete target. CocoaPods再遇困难,前几天电脑重装了系统,所有的开发工具就都...
  • sjl_leaf
  • sjl_leaf
  • 2016年01月12日 18:40
  • 62864

The dependency `AFNetworking` is not used in any concrete target.

最近用到cocoapods安装第三方库的时候遇到这个问题,问题说的是这个库不属于任何target,Google一下发现也有不少人遇到过,特此记录一下 解决办法: target ‘YourProj...

关于The dependency `AFNetworking` is not used in any concrete target的问题

由于coocapods更新,最近用到cocoapods安装第三方库的时候遇到了很多的问题,其中有一个The dependency `第三方库名称` is not used in any concret...

CocoaPods报错:The dependency `AFNetworking ` is not used in any concrete target

本文转载自:http://blog.csdn.net/sjl_leaf/article/details/50506057感谢原作者 ex:The dependency ` is not used i...

当陷进慢性质的困难处境的时候,该如何做?

毕业从事自己“喜欢”的行业也接近1年了

很多事情就像是旅行一样,当你决定要出发的时候,最困难的那部分其实就已经完成了

讲三个故事。第一个。上个月参加了朋友的毕业典礼——他刚从北美 Top10的商学院拿到PhD,现在美国一家顶尖的零售业公司做经理。这位老兄十多年前来到美国时几乎一无所有,在餐馆打工,洗碗,送外卖。送外卖...

十种迹象表明:中国经济最困难时候已经来临

有人说中国能在这场世界性经济危机面前独善其生,种种迹象表明,明年和后年才是中国的困难年头,这两年过去,中国能挺过去的话,将慢慢发展,如果挺不过去,印度尼西亚的今天就是我们的明天。以下可以说明。 1、...
  • mathlmx
  • mathlmx
  • 2011年12月04日 09:22
  • 1392

cocoapods的安装 遇到 Error installing pods:activesupport requires Ruby version >=2.2.2

1.打开终端 2 移除现有 Ruby 默认源 输入以下指令 $gem sources --remove https://rubygems.org/ 3.使用新的源 输入以下指令  ...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:使用pods的时候再次遇到了一些困难
举报原因:
原因补充:

(最多只允许输入30个字)