关闭

安装Eclipse3.2,配置Tomcat,lomboz,PHP,JS插件

2543人阅读 评论(0) 收藏 举报
本文所讲例子均基于Window操作系统.仅作参考--Jiarry(Jarry).

eclipse是一个非常优秀Java编辑开发平台,可惜默认不提供对jsp的支持.

安装eclipse其实非常简单,只要去eclipse.org下载最新的SDK版本就可以了,解压缩文档就是可执行文件,eclipse都是不用安装直接运行的。
eclipse的插件非常多,熟练利用插件将会非常方便各种各样的开发.
本文主要介绍如何利用eclipse开发TOMCAT下的java以及jsp(当然前提是已经配置好了,JDK以及Tomcat了).以及如何使用多语言版本的问题.本文同时适用windows以及linux.

1,下载软件.本文中主要3.2版本来介绍.
写本文时eclipse3.2才刚出来.有些插件可能还有点问题.所以暂时还是建议使用稳定的3.2版的eclipse.当然如果一段时间以后,还是建议使用更新的版本,因为那样功能更多、更全.
eclipse SDK:windows下载eclipse-SDK-3.2-win32.zip,linux下载eclipse-SDK-3.2-linux-gtk.tar.gz压缩包.
Tomcat支持插件去http://www.sysdeo.com/下载:tomcatPluginV3.zip
语言包插件:NLpack-eclipse-SDK-3.2.x-win32.zip。(如果原意用英文的可以不下载此包)
支持jsp开发提示以及高亮语法插件: lomboz需要两个包(如果是all-in-one,就是一个包,如org.objectweb.lomboz-all-in-one-R-3.2http://forge.objectweb.org/project/download.php?group_id=97&file_id=7226)
1,去http://download.zh.forge.objectweb.org/lomboz/lomboz-and-prereqs-S-3.2RC2-200608081203.zip 或:http://download.zh.forge.objectweb.org/lomboz/ 下载最新的
2,去http://download.zh.forge.objectweb.org/lomboz/lomboz-S-3.2RC2-200608081203.zip 下载
PHP支持http://phpeclipse.de/网站下载与eclipse版本对应的插件(安装见专门介绍)
JS高亮语法插件:去http://www.interaktonline.com/ 下载: JSEclipse

2,下载完以上压缩包之后,分别解压
lomboz-all-in-one 里的解压缩至eclipse目录下即可,比如将plugins下全部文件拷贝至eclipse文件夹plugins下面,lomboz里的features下全部文件拷贝至eclipse文件夹 features下。若下载的不是lomboz-all-in-one ,那也作同样处理。NLpack-eclipse-SDK-3.0.x-win32语包也作同样处理(不推荐用中文,用英文就挺好)。 tomcatPluginV3.2.zip解压缩后,将得到的文件夹下的全部文件(这里就一个com.sysdeo.eclipse.tomcat_3.2文 件夹)也拷到eclipse文件夹plugins下面。这样插件算是安装完毕啦,若有其它插件也照些安装。很简单吧!

3,在没有运行eclipse之前(一 定要是之前,否则可能汉化不全面之类,如果已经启动过eclipse了,那就删除configuration文件夹),将各个features以及 plugins下的文件分别拷贝至eclipse的features与plugins目录下,tomcat补丁包要放置在plugins里。

4,然后再运行eclipse(windows下是eclipse.exe,linux下就是eclipse,在linux下可以建立一个符号链接,并选择eclipse的icon.xpm来作为图标)

5,运行eclipse就会发现lomboz和tomcat的图标
这时还要再配置下tomcat。选择window>preferences,java项一般自动配置好了,tomcat需要按你的安装目录指定.然后是lomboz,
要 配置Server Definitions,将Server types改为Apache Tomcat v5.x.x.把properties里的Application Server Directory和环境变量Classpath Variable,两者都是tomcat根目录.比如/usr/local/tomcat5或者d:/tomcat5,地址,端口号等若没改过就不用修 改.tomcat默认是8080.再就是添加Server Classpath,增加tomcat下common/lib的servlet-api.jar,jsp-api.jar,jasper- runtime.jar就可以了.所有更改都别忘点击应用(Apply).
6,然后还要定制视图(Window > Customize Perspective),将Java>Lomboz J2EE Wizards勾中.切换到commands,勾选
中Lomboz Actions.

退 出后重启,新建一个tomcat项目看下,新建java一个文件吧.java文件都放在src下了,并将class自动编译到classes下了.新建一 个jsp文件,就会发现支持jsp高亮语法显示,并且有自动提示的哦.就象Jbuilder一样.Eclipse可是免费的开源软件哦.当然新建 Lomboz项目和文件也是一样方便的,功能还要强大哦.

总之,Eclipse是一款极其优秀的Java,jsp开发平台,在linux下与windows下均能发挥优秀的性能。
写这篇时基于之前安装3.2时候的记录,我用3.0.1感觉也不错,Tomcat,JSP,PHP,JavaScript均支持的相当好。http://www.blogjava.net/hongjunli/archive/2006/08/13/63360.aspx

参考链接:
http://blog.sina.com.cn/u/40e1d62e010004xy
http://www.eclipseworld.org/bbs/read.php?tid=7279
上一篇(安装Eclipse3.x,配置Tomcat,lomboz以及安装中文包)
Eclipse3.2中 Java Web 开发环境的搭建之LOMBOZ+TOMCAT 安装
http://www.blogjava.net/hongjunli/archive/2006/08/13/63360.aspx
Eclipse3.2中 Java Web 开发环境的搭建之LOMBOZ+TOMCAT 安装及验证[8月27号更新]


1,eclipse 3.2 JDK
下载:http://www.eclipse.org/

2,tomcatPluginV32beta2
下载:http://www.sysdeo.com/sysdeo/eclipse/

3,org.objectweb.lomboz-all-in-one-R-3.2-200610201336-win32.zip
下载:http://download.zh.forge.objectweb.org/lomboz/
如非all-in-on需要下载:lomboz-and-prereqs-S-3.2 以及 lomboz-S-3.2RC2

4,net.sourceforge.phpeclipse1.8.src.zip
下载:http://phpeclipse.de/

5,JSEclipse_1[1].5.2.2
下载:http://www.interaktonline.com/Products/Eclipse/JSEclipse/Overview/


(解压缩是可将压缩包copy至根目录,否则可能名称路径太长而无法解开)

plugins 对应 plugins,向tomcat插件直接放置plugins下。
features 对应 features
采用link方式调用插件也可以,网上有很多例子。

 
0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:3333次
    • 积分:40
    • 等级:
    • 排名:千里之外
    • 原创:1篇
    • 转载:1篇
    • 译文:0篇
    • 评论:0条
    文章存档