【网络流之最大流】HDU3549Flow Problem【EK模板】

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3549

Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
  
  
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
  
  
Case 1: 1 Case 2: 2

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<queue>
using namespace std;
const int MAXN=1010;
int n,m,st,ed;
int Map[MAXN][MAXN],pre[MAXN],path[MAXN],flow[MAXN];
int bfs()
{
    queue<int>q;
    memset(path,-1,sizeof(path));
    path[st]=0;
    flow[st]=1<<29;
    q.push(st);
    while(!q.empty()){
        int t=q.front();
        q.pop();
        if(t==ed) break;
        for(int i=1;i<=n;i++){
            if(path[i]==-1&&Map[t][i]){
                flow[i]=min(flow[t],Map[t][i]);
                q.push(i);
                path[i]=t;
            }
        }
    }
    if(path[ed]==-1) return -1;
    return flow[ed];
}
int EK()
{
    int max_flow=0,now,pre,Flow;
    while((Flow=bfs())!=-1){
        max_flow+=Flow;
        now=ed;
        while(st!=now){
            pre=path[now];
            Map[pre][now]-=Flow;
            Map[now][pre]+=Flow;
            now=path[now];
        }
    }
    return max_flow;
}
int main()
{
    cin.sync_with_stdio(false);
    int t,Case=1,u,v,c;
    cin>>t;
    while(t--){
        cin>>n>>m;
        memset(Map,0,sizeof(Map));
        for(int i=0;i<m;i++){
            cin>>u>>v>>c;
            Map[u][v]+=c;
        }
        st=1,ed=n;
        cout<<"Case "<<Case++<<": "<<EK()<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值