【快速幂】HDU1211RSA

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1211

Problem Description
RSA is one of the most powerful methods to encrypt data. The RSA algorithm is described as follow:

> choose two large prime integer p, q
> calculate n = p × q, calculate F(n) = (p - 1) × (q - 1)
> choose an integer e(1 < e < F(n)), making gcd(e, F(n)) = 1, e will be the public key
> calculate d, making d × e mod F(n) = 1 mod F(n), and d will be the private key

You can encrypt data with this method :

C = E(m) = m e mod n

When you want to decrypt data, use this method :

M = D(c) = c d mod n

Here, c is an integer ASCII value of a letter of cryptograph and m is an integer ASCII value of a letter of plain text.

Now given p, q, e and some cryptograph, your task is to "translate" the cryptograph into plain text.
 

Input
Each case will begin with four integers p, q, e, l followed by a line of cryptograph. The integers p, q, e, l will be in the range of 32-bit integer. The cryptograph consists of l integers separated by blanks. 
 

Output
For each case, output the plain text in a single line. You may assume that the correct result of plain text are visual ASCII letters, you should output them as visualable letters with no blank between them.
 

Sample Input
  
  
101 103 7 11 7716 7746 7497 126 8486 4708 7746 623 7298 7357 3239
 

Sample Output
  
  
I-LOVE-ACM.

代码:

#include<iostream>
#include<map>
#define LL long long
using namespace std;
//  计算a^b%n;快速幂
LL power_mod(LL a,LL b,LL n)
{
    LL ans=1;
    while(b){
        if(b&1)ans=(ans*a)%n;
        b>>=1;
        a=a*a%n;
    }
    return ans;
}
int main()
{
    int p,q,e,l,c;
    cin.sync_with_stdio(false);
    while(cin>>p>>q>>e>>l){
        LL n=q*p;
        map<LL,char>a;      //  开不了这么大的数组,选择用map;
        for(int i=0;i<255;i++){
            a[power_mod(i,e,n)]=(char)i;
        }
        for(int i=0;i<l;i++){
            cin>>c;
            cout<<a[c];
        }
        cout<<endl;
    }
    return 0;
}
/*
    通过给定我们密文,我们不易获得明文,
    但是给我明文,我们可以很轻松的获得密文;
    ASCII总共255个,预处理就可以了
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值