POJ 1274 二分图最大匹配

          一道很裸很裸的二分图匹配。。。。刚做了我们学校oj上的一道二分图匹配,,,所以这道题很快就1A了,,,,水题,,题目:

The Perfect Stall
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12137 Accepted: 5632

Description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 

Input

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2 

Sample Output

4
ac代码:

#include <iostream>
#include <string.h>
#include <vector>
#include <cstdio>
using namespace std;
vector<int> aa[205];
int flag[205],visted[205];
bool dfs(int x){
	for(int i=0;i<aa[x].size();++i){
		if(!visted[aa[x][i]]){
		  visted[aa[x][i]]=1;
		  if(!flag[aa[x][i]]||dfs(flag[aa[x][i]])){
		    flag[aa[x][i]]=x;
			return true;
		  }
		}
	}
	return false;
}
int main(){
  int n,m;
  while(~scanf("%d%d",&n,&m)){
	memset(aa,0,sizeof(aa));
	memset(flag,0,sizeof(flag));
    int num,x;
	for(int i=1;i<=n;++i){
	  scanf("%d",&num);
	  while(num--){
	    scanf("%d",&x);
		aa[i].push_back(x);
	  }
	}
	int sum=0;
	for(int i=1;i<=n;++i){
	  memset(visted,0,sizeof(visted));
	  if(dfs(i))
		  sum++;
	}
	printf("%d\n",sum);
  }
  return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值