POJ 3660 floyd 算法

         是一道floyd变形的题目。题目让确定有几个人的位置是确定的,如果一个点有x个点能到达此点,从该点出发能到达y个点,若x+y=n-1,则该点的位置是确定的。用floyd算发出每两个点之间的距离,最后统计时,若dis[a][b]之间无路且dis[b][a]之间无路,则该点位置不能确定。最后用点个数减去不能确定点的个数即可。题目:

Cow Contest
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4813 Accepted: 2567

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2
ac代码:

#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;
#define MAX 0x7fffffff
const int N=110;
int dis[N][N];
int n,m;
void floyd(){
	for(int k=1;k<=n;++k){
		for(int i=1;i<=n;++i){
			for(int j=1;j<=n;++j){
				if(dis[i][k]!=MAX&&dis[k][j]!=MAX&&dis[i][j]>dis[i][k]+dis[k][j]){
				  dis[i][j]=dis[i][k]+dis[k][j];
				}
			}
		}
	}
}
int main(){
	//freopen("1.txt","r",stdin);
	while(~scanf("%d%d",&n,&m)){
		for(int i=1;i<=n;++i){
		  for(int j=1;j<=n;++j)
			  dis[i][j]=MAX;
		}
	  int x,y;
	  while(m--){
	   scanf("%d%d",&x,&y);
	   dis[x][y]=1;
	  }
	  floyd();
	  int ans=0;
	  for(int i=1;i<=n;++i){
		  for(int j=1;j<=n;++j){
			if(j==i)continue;
		    if(dis[i][j]==MAX&&dis[j][i]==MAX)
			{ans++;break;}
		  }
	  }
	  printf("%d\n",n-ans);
	}
  return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值