NYOJ 479 欧拉函数

    水题,不解释。。。题目:

Coprimes

时间限制: 500 ms  |  内存限制: 4096 KB
难度: 1
描述
For given integer N (1 <=N <=10 4) find amount of positive numbers not greater than N that coprime with N. Let us call two positive integers (say, A and B, for example) coprime if (and only if) their greatest common divisor is 1. (i.e. A and B are coprime iff gcd(A,B) = 1).
输入
Input file contains integer N.( 注意:程序以文件结束符“EOF”结束输入。)
输出
Write answer in output file. 每个数字占一行。
样例输入
9
样例输出
6
ac代码:

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int main(){
  int n;
  while(~scanf("%d",&n)){
    int ans=n;
	int m=sqrt(n+0.5);
	for(int i=2;i<=m;++i){
	  if(n%i==0)
		  ans=ans-ans/i;
	  while(n%i==0)
		  n/=i;
	}
	if(n>1)ans=ans-ans/n;
	printf("%d\n",ans);
  }
  return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值